I have a tomcat server running on my pc which I can access locally via: http://localhost:9090 (I changed the ports in the server.xml file). Now, I am having trouble accessing the tomcat server remotely (i.e. a different machine, I can test this with machines outside or inside of my LAN).

Anyway, what I have tried is using the netgear genie interface to configure port forwarding. I have set all internal and external ports to 9090 (I tried using 80 for internal and 8080 for external but I they were already being used).

When I point my browser to: http://my-ip-address:9090 and it just times out... If I don't add a port, I am prompted with a username and password with a message box that says:

A username and password are being requested by http://my-ip-address. The site says: "SMC Dual WAN Load balancing VPN Router Administration Tools"

This is NOT the same as the username and password that I needed to login to the netgear genie interface. Note that I use Ubuntu (12.04, 13.04 and 14.04) and tomcat7.

Please help me get connected to my tomcat server remotely.

Thanks for all the help, and let me know if you need any more information.

  • Are you aware of what's on your network? Nov 1 '14 at 13:17
  • 1
    @MichaelHampton what do you mean? I have little to no exposure to networking -- I learned a ton yesterday by just trying to get this to work. Nov 1 '14 at 18:59
  • 1
    On the Tomcat server, what says netstat -anp | grep 9090 ?
    – krisFR
    Nov 2 '14 at 1:52

First, Did you perform the port-forwarding on your gateway to port 9090? Btw, you can set the external port to 9090 and the internal to 80 .. this will work with you.

Second, Can you confirm that your server is running correctly? Try executing netstat -an | grep 9090 where 9090 is your port. If you don't see it, restart the tomcat service.

Finally, try connecting for a machine in your LAN first to rule out any invalid possibility for the failure. Point the browser on any local machine to http://:9090

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.