1

I am running a Prestashop installation on CentOS 6.5 and Apache 2.2.15. A while back I updated Apache and lost the ability to upload product images via Prestashop backoffice along with other problems, such as permission problems with the cache folder inside my Prestashop installation.

My Prestashop installation folders and files are set to user1:psacln, and I would imagine my Apache was set to run with this user and group before I updated it. Now, however, Apache is set to run with apache:apache, and I presume this is causing the problems. However, when I change Apache to run as user1:psacln I get these errors in /var/log/httpd/error_log:

[error] (13)Permission denied: mod_fcgid: couldn't bind unix domain socket /var/run/mod_fcgid/sock/20507.202
[warn] (13)Permission denied: mod_fcgid: spawn process /var/www/cgi-bin/cgi_wrapper/cgi_wrapper error

I tried setting chown -R user1:psacln /var/run/mod_fcgid, but after this I just got Internal Server Error 500 when connecting to the site.

Thus, I suppose my real question is exactly where do I have to make changes besides httpd.conf (user, group) to make things tick properly with FastCGI?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.