0

I have an SSL site I'm trying to deliver with apache that is timing out when you load it in a web browser.

I am seeing this message in the browser:

The connection has timed out

The server at solr1.mydomain.com is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

I checked the logs and I am seeing SSL errors in the logs that say:

[Sun Nov 02 17:43:13.859447 2014] [ssl:warn] [pid 23687] AH01909: RSA certificate configured for solr1.mydomain.com:443 does NOT include an ID which matches the server name

Which is strange. Because when creating the certs for the site, I made sure to specify the output of hostname -f on the server for the common name.

This is an amazon EC2 instance. I'm not sure if that could have something to do with this problem.

Here is my apache configuration:

LoadModule    jk_module  modules/mod_jk.so
JkWorkersFile /etc/httpd/conf/workers.properties
JkShmFile     /var/log/httpd/mod_jk.shm
JkLogFile     /var/log/httpd/mod_jk.log
JkLogLevel    info
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "

Virtual Host config:

 <VirtualHost *:80>
   ServerName solr1.mydomain.com
   ErrorLog logs/solr1_error_80_log
       LogFormat "{ \
           \"host\":\"solr1.mydomain.com\", \
      \"path\":\"/var/log/httpd/solr1_access_log\", \
      \"tags\":[\"mydomain Trac 80\",\"solr1.mydomain.com\"], \
      \"message\": \"%h %l %u %t \\\"%r\\\" %>s %b\", \
      \"timestamp\": \"%{%Y-%m-%dT%H:%M:%S%z}t\", \
      \"clientip\": \"%a\", \
      \"duration\": %D, \
      \"status\": %>s, \
      \"request\": \"%U%q\", \
      \"urlpath\": \"%U\", \
      \"urlquery\": \"%q\", \
      \"method\": \"%m\", \
      \"bytes\": %B, \
      \"vhost\": \"%v\" \
    }" solr1_access_json
   CustomLog  logs/solr1_80_access_log solr1_80_access_json
   RewriteEngine On
   RewriteCond %{HTTPS} off
   RewriteRule (.*) https ://%{HTTP_HOST}%{REQUEST_URI}
   RewriteRule  ^/$    /solr [L,R=301]

   </VirtualHost>

   <VirtualHost *:443>
   RewriteEngine On
   RewriteRule  ^/$    /solr [L,R=301]

   ServerName solr1.mydomain.com
   ErrorLog logs/solr1_error_443_log
   LogFormat "{ \
      \"host\":\"solr1.mydomain.com\", \
      \"path\":\"/var/log/httpd/solr1_443_access_log\", \
      \"tags\":[\"mydomain Trac 443\",\"solr1.mydomain.com\"], \
      \"message\": \"%h %l %u %t \\\"%r\\\" %>s %b\", \
      \"timestamp\": \"%{%Y-%m-%dT%H:%M:%S%z}t\", \
      \"clientip\": \"%a\", \
      \"duration\": %D, \
      \"status\": %>s, \
      \"request\": \"%U%q\", \
      \"urlpath\": \"%U\", \
      \"urlquery\": \"%q\", \
      \"method\": \"%m\", \
      \"bytes\": %B, \
      \"vhost\": \"%v\" \
    }" solr1_443_access_json
   CustomLog  logs/solr1_443_access_log solr1_443_access_json

   SSLEngine on
   SSLCertificateFile /etc/pki/tls/certs/solr1.crt
   SSLCertificateKeyFile /etc/pki/tls/private/solr1.key

   # Select the timestamp log format
   JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
   # Send everything for context /examples to worker named worker1 (ajp13)
   <Directory /usr/share/tomcat/webapps/solr>
      Options  +Indexes +FollowSymLinks
      AllowOverride All
      Order allow,deny
      allow from all
    </Directory>

   Alias /solr /usr/share/tomcat/webapps/solr
   JkMount  /test/* worker1
   JkMount  /solr/* worker1

   <Location "/solr/">
     AuthType Basic
     AuthName "JF Admin Page"
     AuthUserFile /etc/httpd/auth
     Require valid-user
   </Location>

 </VirtualHost>

I'm hoping I can get some advice that can help me get past this problem!

  • I'm pretty sure that's not your domain name. Anyway you should check your security group and host firewall. – Michael Hampton Nov 3 '14 at 1:24
  • How could you tell that's not my domain? ;) anyway, yup! Brain fart. It was the SGs... sigh.. but thank you! – user99201 Nov 3 '14 at 1:59
1

If it takes too long then make sure that 443 is not blocked by your ISP. Make sure it is forwarded to correct IP (web server) and web server is listening mode. Online port scanners are kind of confusing as some maybe 443 is open and some may report it as closed port. Sometimes it is also related to router firmware, you can try with another router and if you still get problem call your ISP and ask them if that port is open or not.

| improve this answer | |
  • It looks like the OP solved his issue in the comments. – Katherine Villyard Sep 2 '16 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.