2

I have a Squid server setup with ssl-bump caching SSL resources used by Docker but I'm having issues trying to get it to cache requests to Cloudfront, for example:

1415056176.733 190419 172.17.0.40 TCP_MISS/200 221665373 GET https://dseasb33srnrn.cloudfront.net/images/8ca2483ec35c2a51b0a241eac48c40b1db6870be14d0507772a05a1bc565bf7e/layer? - PINNED/54.230.141.138 binary/octet-stream

1415055736.782 159755 172.17.0.9 TCP_MISS/200 221665364 GET https://dseasb33srnrn.cloudfront.net/images/8ca2483ec35c2a51b0a241eac48c40b1db6870be14d0507772a05a1bc565bf7e/layer? - PINNED/54.230.140.173 binary/octet-stream

I see it could be because of the query parameters send to Cloudfront (or the headers returned) but given this config is there a way to explicitly force Squid to cache the content?

acl docker_image_layer url_regex .*/images/.*/layer
request_header_access Accept-Encoding deny docker_image_layer
refresh_pattern -i . 3600    80%     14400

As Docker does hit https://registry-1.docker.io/v1/images/XXX/layer initially but encounters a redirect, is it possible to cache the end result of a redirect?

  • Can you show the cache configurations in your squid file? (i.e. cache_dir, maximum_object_size, etc.) – theterribletrivium Nov 4 '14 at 0:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.