I'm trying to get LogParser 2.2 running on Windows Server 2012. When I attempt to run LogParser from the command prompt (just trying LogParser -h) I get a User Account Control dialog asking if I want to allow LogParser to make changes to this computer. When I select Yes, I see another command window flashing up briefly then closing again and no output to the command window I entered the command into.

I've set the LogParser.exe to always run as administrator (selected LogParser.exe in File Explorer, right clicked, selected Troubleshoot compartibility from the context menu to open the Program Compatibility Troubleshooter).

I'm logged in as is a local administrator on the server. I've previously run LogParser successfully on my Windows 8.1 PC but this is the first time I've tried to install it on a Windows Server 2012.

I suspect I'm missing something obvious. Can anyone give me any ideas on what I'm doing wrong or missing?


Turns out the problem was running LogParser as administrator. It didn't need elevated privileges. Once I stopped running it as administrator it worked fine, displaying the results in the same command window I was running it from.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.