1

In my runlist for one of my nodes, I have "recipe[logstash::server]". When I run chef-client on the node, the following error is thrown:

The following cookbooks are required by the client but don't exist on the server: * logstash

When I run knife cookbook list I see logstash, and when I run knife cookbook upload logstash -o vendors/cookbooks/ the cookbook uploads successfully.

  • The node is really connecting to the same chef server? – StephenKing Nov 5 '14 at 18:39
  • Yes, there is only one. – mako_reactor Nov 5 '14 at 18:57
  • 1
    have you double checked versions? Sometimes you can get that error when the version of the cookbook needed by the environment is not available on the server. – Tejay Cardon Nov 6 '14 at 21:37
  • Had the same problem. Turns out one of my environments had this cookbook locked to a particular version with chef_environment's cookbook_versions. So it was a typo on my part. – Victor Piousbox Jan 13 '16 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.