4

I have a web server hosting multiple domains (centos + postfix + dovcot), one of my domain its dns is hosted on cloudflare (ie. abcd.com), but when I use gmail to send email to a user@abcd.com, user@abcd.com will not be able to receive the email. Here is the MX record I set in cloudflare:

Type   Name   Value                                       TTL          Active
mx     mail   handled by mail.abcd.com with priority10    Automatic     
cname  mail   is an alias of abcd.com                     Automatic    grey cloud

Any knows how can I make the domain receive the emails?

7

You have two distinct errors in your configuration:

  1. The MX record should be for your domain, not for a subdomain.

  2. An MX record should not point to a CNAME. Point it to a record with an IP address.

An example of a working domain:

CloudFlare DNS settings

| improve this answer | |
  • 1
    i tested your config, but the email only can be received when the domain name(not mail) A record is in grey cloud (ie first row of your pic) , so it stills blocking my email – hkguile Nov 8 '14 at 15:36
  • It's supposed to be a gray cloud. – Michael Hampton Nov 8 '14 at 15:39
  • 1
    but your pic yes-www.org A record is in orange – hkguile Nov 8 '14 at 15:41
  • 1
    But that is not the record that the MX record points to! – Michael Hampton Nov 8 '14 at 15:45
  • @hkguile Please do yourself a favour and find out what grey and orange clouds mean. mail is supposed to be grey because this means cloudflare does NOT CACHE THE CONTENT - it is not acting as a SMTP buffer. It does so for all websites (which is what a CDN does). – TomTom Feb 9 '16 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.