I'm trying to uninstall a program from Windows Server 2012, but when I do, it tells me:

Error 1721: There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.

This error seems fairly common through Google, but the steps I've found so far haven't worked:

  • Restart in safe mode and unregister and re-register msiexec - result: no output, uninstall still doesn't work
  • Run the System File Checker (sfc /scannow) - result: No anomalies found
  • Run the Windows Installer Cache diagnostic - result: server unable to communicate with diagnostic through corporate firewall
  • Run the Program Install and Uninstall auto-fixer - result: server unable to communicate with diagnostic through corporate firewall

I've also tried repairing the installation (which succeeds) and uninstalling, but it still fails with the same error. I can't re-install Windows Installer because it's Server 2012, comes as part of the O/S, and has no redistributable available. I'm tempted to rip the entry out of the uninstall key in the registry and see if it'll let me to a new install over top of the existing one, and then uninstall it, but thought I'd see if anyone has any better ideas.

FWIW, the software I'm trying to uninstall is Bentley iCS for PDF V8i (SELECTseries 4); there's a new version that needs to be installed, and it won't install until the previous version is uninstalled.

Any assistance or thoughts would be appreciated. Thanks.

1 Answer 1


Are there other dependencies that go with the program? Those may have to be removed first and then you can try removing the actual program. A quick search shows that your program runs inside Orchestration Framework Administrator. Is that something that can be uninstalled? If so, get rid of it, then iCS and then install the new iCS (and framework, of course).

  • Well, if iCS is dependent on Orchestration Framework, wouldn't the dependency go the other way? I gave it a shot anyway, and while the framework uninstalled fine, iCS still gave the same error.
    – DarkMoon
    Nov 11, 2014 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.