1

We have a router (8 ports) that serves our church (it also is our modem with ADSL2 etc) and handles our DHCP services.

I've needed to extend our network to accomodate another 2 ports, so an extra router was bought (8 ports), installed with OpenWRT. We need this router to be a switch but use a different DNS server due to the business requirements.

I'm trying to workout how to configure the OpenWRT router (192.168.1.x) so that it still see's our core NAS (192.168.0.x) but any machines connecting to it uses the DNS's set on it rather than the Google DNS servers (or ISP ones) on the main router. It would also be nice for it to reside on the 192.168.0.x subnet (maybe .100+)

Is it as simple as turning off DHCP on the OpenWRT router and setting up the DNS or is there something else I need to do? I'd still like to have a static IP for the OpenWRT router so I can configure it via the web interface (Luci).

Trying it out earlier - disable DHCP, giving it a static IP and restarting, yielded no accessible IP for the router. So I had to reset the router.

Any ideas would be greatly appreciated.

3
  • 1
    If you need a switch then return the router and buy a switch. If clients plugged into the 'new' router are not working correctly with a manually set DNS server setting on the client, then either you've configured the new router wrongly (a problem that could be avoided by using a switch instead) or the DNS server address is incorrect. – Rob Moir Nov 11 '14 at 12:55
  • Clients plugged into the new router aren't seeing the computers on the other subnet. We'd like them to access our NAS - sorry if this was unclear above. – andrej Nov 12 '14 at 9:37
  • If they're not even seeing the NAS by IP address then this supports the idea that you've probably mis-configured the router and should be using a switch instead. – Rob Moir Nov 12 '14 at 12:08
1

It sounds very much like you're trying to set the new router to be functioning like a switch. As suggested by RobM you should opt for a switch instead - unmanaged would be cheaper and plug n play!

However, if your want to continue to use that router, I have a feeling your router also has an internet port and you've probably got that port linking from your other modem - after you configure your OpenWRT to not do DHCP and have a static IP.

Instead, try and plug it into one of your main ports (of 8). That should fix it. As for DNS, you can try setting up some rules for DNS forwarding.

I use it currently for Netflix but it's configured like:

/netflix.com/222.53.156.36
/netflix.com/212.122.161.12

Under LUCI I thjink its Network -> DHCP and DNS.

1
  • thaanks that was it! – andrej Nov 13 '14 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.