1

I had a owncloud working on my ubuntu server and the data folder was /var/owncloud/data After a major update of Ubuntu it did not work any more, so I re-installed owncloud

The /var/owncloud/config/congig.php file is pointing to the same original data folder:

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxx',
  'passwordsalt' => 'xxxxxx',
  'datadirectory' => '/var/owncloud/data',
  'dbtype' => 'mysql',
  'version' => '5.0.20',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_xxxx',
  'dbpassword' => 'xxxxxx',
  'installed' => true,
);
?>

And in the the default-ssl.conf in sites-available the owncloud base folder is set:

<IfModule mod_ssl.c>
#   <VirtualHost _default_:443>
    <VirtualHost *:443>
    ServerAdmin eric@tillandsia.nl
    ServerName tillandsia.nl
    ServerAlias www.tillandsia.nl

    DocumentRoot /var/www
    <Directory />
            Options FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/ssl_access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    SSLEngine on
    SSLCertificateFile    /etc/apache2/ssl/owncloud.pem
    SSLCertificateKeyFile /etc/apache2/ssl/owncloud.key

    <FilesMatch "\.(cgi|shtml|phtml|php)$">
            SSLOptions +StdEnvVars
    </FilesMatch>
    <Directory /usr/lib/cgi-bin>
            SSLOptions +StdEnvVars
    </Directory>
    BrowserMatch "MSIE [2-6]" \
            nokeepalive ssl-unclean-shutdown \
            downgrade-1.0 force-response-1.0
    BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

    <Directory /var/owncloud>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Require all granted
            Satisfy Any
    </Directory>
</VirtualHost>
</IfModule>

When accessing from a client, it starts in /var/lib/owncloud instaid of the original data folder. What can I do to get it back to the original folder?

  • Can you post the full VirtualHost configuration rather than just a snippet? – Craig Watson Nov 12 '14 at 15:40
  • You will need to edit your question instead of pasting into comments ... – Craig Watson Nov 12 '14 at 23:54
  • It does not show the whole start and end:<IfModule mod_ssl.c> <VirtualHost *:443> ServerAdmin eric@tillandsia.nl ServerName tillandsia.nl ServerAlias www.tillandsia.nl</VirtualHost> </IfModule> – longEric Nov 13 '14 at 0:11
  • Craig, any idea? Eric – longEric Nov 14 '14 at 12:30
  • I'm afraid I can't see how Apache would even serve from /var/lib/owncloud - you may have other Apache configuration files which is specifying that directory. – Craig Watson Nov 14 '14 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.