0

Currently configuring a mail server using Postfix/Dovecot on Ubuntu 14.04 x86. At the moment I'm trying to setup DKIM using OpenDKIM. The guide I am following tells us to put the parameter "non_smtpd_milters=inet:localhost:8891" in /etc/postfix/main.cf. However, when I service postfix restart I get many warnings:

* Starting Postfix Mail Transport Agent postfix      
postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: non_smptd_milters=inet:localhost:8891

Does anyone have any idea how to solve this?

A copy of my main.cf can be found here: http://pastebin.com/mLnUdFHS

5
  • non_smptd_milters!=non_smtpd_milters See the documentation – masegaloeh Nov 12 '14 at 19:57
  • @masegaloeh Thanks for your comment. Unfortunately, I'm not sure I understand. Those two parameters look the same to me, and the documentation doesn't make it any clearer to me :( Sorry! Would you mind elaborating? – Aeth Nov 12 '14 at 20:10
  • Documentation says s m t p d. Your config says s m p t d. – masegaloeh Nov 12 '14 at 20:13
  • Ahhhhhhh..... I am truly blind. Thank you SO much. I've seen too many ss, ms, ts and ps today... – Aeth Nov 12 '14 at 20:14
  • Posted it in answers section. Please consider to accepting it so this question doesn't float in unanswered pool. – masegaloeh Nov 13 '14 at 2:43
5

You misspelled parameter non_smtpd_milters. Your config says non_smptd_milters not non_smtpd_milters.

How I spot it: Googling for keyword non_smptd_milters would yield 5 results, but for keyword non_smtpd_milters would yield thousands result.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.