Utilizing internal USB drives on the motherboard I have been attempting to implement BitLocker onto our physical servers. I have tried 6 of them, all HP servers and all of them give the same error. After encrypting to 99.9% (go figure) it pauses with an error message:

This disk has one or more errors. Run "chkdsk /r". If these errors persist this may be indicative of hardware fault.

I would have assumed after one server, maybe it could have been hardware related...but all 6 seems rather unlikely. I have run chkdsk /r as well as chkdsk /r /b /f neither of which has solved the issue. We are running hardware raid on these machines...I cannot find anything definitively stating BitLocker does not support hardware RAID though I have seen a few items pointing out it does not support software RAID...

Any ideas here...? I am at a lost...

The Log I receive: Error Event ID: 24586 Bitlocker-Driver


It appears the issue was due to not creating separate partitions. As per the BitLocker tutorial from Microsoft two partitions should be created, however those may only be created if bdehdcfg -driveinfo returns selected disks to modify. If it returns a message detailing how the drive is setup already and it is not necessary you may not modify the disks utilizing bdehdcfg. For some unknown reason this was occuring even though my disks were NOT ready for BitLocker at all. I actually had to reload windows... Makes no sense at all. But works now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.