0

I'm experimenting with setting up an azure site-to-site vpn. I had a test server already set up and working in a subscription. The server had internet access but no vpn link.

I ran through the options to create a site to site vpn and it came up without any great problems. the on-prem firewall says its connected. I followed one of the online examples where I used 10.10.0.0/16 and created two subnets 10.10.1.0/24 and 10.10.2.0/24

My problem is that my server doesn't seem to be in any way linked to this new virtual network I've created. I've tried rebooting it just in case but it comes back up with an ip in the 100. range which azure gives out to new machines. I expected it to have an address in the 10.10. range, or maybe a second interface.

What I have is a VM + Virtual network under the same subscription. Both work independently.

I've spent hours digging through blogs and docs and can't find anything which helps. If I try to create a new test vm under this subscription, when I get to the "Choose A Region/Affinity group/Virtual Network" I can choose the virtual network I created, but I can't work out any way to modify the existing vm.

Can anyone suggest what I may be missing?

1

I discovered the answer to my own question. After spending hours and hours on this, I discovered the solution not long after posting this.

The simple answer is, you can't.

Instead you have to remove the vm, but leave its disks and then recreate the vm and attach it to the virtual network.

Answer found thanks to this blog: http://blogs.msdn.com/b/walterm/

  • Just a quick note, you can make the deletion/recreating a bit easier by using the Export-AzureVM cmdlet which will lay down a template file you can use to recreate it. – Trondh Nov 14 '14 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.