0

I use OpenVPN on Ubuntu Server as VPN Server, and Viscosity successfully working with this client configuration:

xxx.no-ip.org remote udp 1194
dev tun
tls-client
ca ca.crt
cert cert.crt
key key.key
tls-auth ta.key 1
persist-tun
persist-key
persist-local-ip
auth-user-pass
comp-lzo no
nobind
pull
dhcp-option DNS 192.168.8.1
BF-CBC cipher

Now, I want to implement that configuration in my Linksys E2500 flash with Tomato (v 1.28 shibby) This configuration of what I have done;

'VPN Tunneling > OpenVPN Client' menu

'Basic' tab:

  • Start with WAN: Check
  • Interface Type: TUN
  • Protocol: UDP
  • Server IP address / Port: 1194 xxx.no-ip.org
  • Firewall: Automatic
  • Authorization / Password Authentication: Check
  • Username: myusername
  • Password: *******
  • Username Authen. Only: Uncheck
  • Extra HMAC authorization (tls-auth): Outgoing (1)
  • Create NAT on tunnel: Uncheck

'Advanced' tab

  • Poll interval: 0
  • Redirect traffic: Uncheck
  • Accept DNS configuration: Strict
  • Encryption cipher: BF-CBC
  • Compression: Disabled
  • TSL Regeneration Time: -1
  • Connection retry: 30
  • Custom Configuration:
    persist-tun
    persist-key
    persist-local-ip
    comp-lzo no
    nobind
    pull
    dhcp-option DNS 192.168.8.1

'Keys' tab

  • Static Key: [content of ta.key file]
  • Certificate Authority: [content of ca.cert file]
  • Client Certificate: [content of cert.crt file]
  • Clent Key: [content of key.key file]

and I was able to do 'Start Now' but this seems not work because I can not access any resources on the network under the VPN server which that I can do when I connect with Viscosity.

So, what I miss?

  • Based on my answer below, this is a NAT issue – Bakti Jan 26 '15 at 4:39
0

After I do some changes, the issue is resolved, following a change of settings above;

'Basic' tab:

  • Create NAT on tunnel: Checked

'Advanced' tab

  • Accept DNS configuration: Relaxed
  • Compression: None
  • Custom Configuration
    persist-tun
    persist-key
    persist-local-ip
    comp-lzo no
    nobind
    pull

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.