0

As the title indicates, I created a startup task in my Azure Web Role to install ARR on the servers, here is the command:

>WebPiCmd /install /Products:"ARRv3_0"

it works locally on my machine, but on the server it gets interrupted and shows a Window message saying the following:

The following features couldn't be installed

.NET Framework 3.5 (Includes .NET 2.0 and 3.0)

Windows Server Roles and Features cannot be automatically installed or uninstalled via the Windows Features Control Panel.

To Install Windows Server Roles and features, Start Server Manager, or use the Server Manager cmdlets for Windows PowerShell.

Installation from the Web Platform Installer GUI works perfectly, and even skips installing .net framework 3.5 entirely, since 4.5 is installed on Windows Server 2012 already.

I tried the offline mode and even editing the feed XML file to remove any references to .NET framework 3.5 but it didn't work.

Anyone has a pointer on how to smoothly install my components?

0

Found the problem, it seems I was deploying the "WebPiCmd/WebPiCmd-x64" executable without the "WebPiCmd-x64.config" file. Adding it solved the problem.

Maybe the missing "supportedRuntime" caused things to go wrong. Anyway here is my version of the file that fixed everything.

<configuration>
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v2.0.50727" />
    <supportedRuntime version="v4.0" />
  </startup>
  <runtime>
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
         <dependentAssembly>
            <assemblyIdentity name="Microsoft.Web.Deployment"
                          publicKeyToken="31bf3856ad364e35"
                          culture="neutral" />
            <bindingRedirect oldVersion="7.1.0.0-7.5.0.0"
                         newVersion="8.0.0.0"/>
         </dependentAssembly>
      </assemblyBinding>
   </runtime>
</configuration>
  • Tried to look it up and help you do the installation using PowerShell, apparently there's no direct way for doing it without going back to the WebPI tools, here's a nice link explaining the procedure in more details: brentdacodemonkey.wordpress.com/2014/02/12/… – Noor Khaldi Nov 16 '14 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.