7

I have to configure the security settings for the SNMP-Service on a Windows Server. But they are missing!

Here are the facts:

  • OS: Windows Server 2012 R2

  • I installed the SNMP feature and I believe, that I already configured the service (but I forgot to add another IP under Security tab)

  • I know the issue where you have to restart the SNMP-service after you installed the feature to see the Security tab (so I made already some restarts.)

  • My colleague installed now the DC server role.

  • Now I can not see the Security tab anymore (I don't know if it has to do something with the installation of the DC role).

  • I really need SNMP for monitoring reasons. (So please don't advise to use WMI or other things)

  • I used my domain admin when clicking on "SNMP-Service" --> "Properties"

What can I do to see the Security tab again? Or is there a possibility to configure the SNMP service via CMD or PowerShell?

5

You need to install the SNMP Tools feature to get those tab pages, e.g. using the Powershell command Install-WindowsFeature RSAT-SNMP.

Remember to restart the service manager before opening the properties page again.

4
  • The OP explictly mentioned in the question that he did that.
    – Sven
    Jan 7 '15 at 9:20
  • 1
    @Sven: Where? I don't see that. Neither in the post, nor in the edit history. Install-WindowsFeature RSAT-SNMP seems correct. Just tested in lab. Blog post for background: Josh Ancel, 2013-04-02, Windows Server 2012 No Security Tab in SNMP Mar 10 '16 at 10:48
  • 1
    that helped instantly. May 24 '16 at 10:34
  • If one just installs SNMP-Service, then they will have the missing configuration tabs under the service. You can then either manage SNMP via GPO or editing the registry. However, as Ingo notes, installing RSAT-SNMP (SNMP Tools) adds in the missing tabs.
    – Andrew S
    Mar 3 '20 at 21:02
3

You need to open the services.msc from an elevated command line window (run as admin). Then you'll get the security tab!

1
  • Some of us IT admins are not using THE domain "administrator" account to manage server. This answer was right on.
    – satoc
    Mar 16 '20 at 6:27
2

Workaround: I fixed this via Registry

I found this site for config via registry:

I set up PermittedManagers and ValidCommunities, and now it seems to work for me!

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\PermittedManagers

REG_SZ

Value name: 1

Value data: (IP address of monitoring server)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\ValidCommunities

REG_DWORD

Value Data: 4

Value Name: (community string)

(But if anyone has a hint why I can't see the Security tab under Properties I would be grateful anyway!)

1
1

I read on another website that closing the service.msc waiting a few seconds and opening it again will make the agent, security and traps tabs appear. Worked for me. https://martcj.wordpress.com/2012/03/29/snmp-service-has-no-agent-traps-or-security-tabs-to-configure-in-windows-2008/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.