1

I have configured a LDAP authenticator in my WebLogic 10.3.2 domain. Login worked until the domain controller was patched with MS14-066 (KB2992611). Domain Controller OS is Win Server2008R2 (x64).

The logfile after a restart of domain service looks like this:

<BEA-000000> <authenticate user:weblogic>
<BEA-000000> <new LDAP connection to host xxx.xxx.com port 636 use local connection is false>
<BEA-000000> <created new LDAP connection LDAPConnection { ldapVersion:2 bindDN:""}>
<BEA-000000> <connection failed netscape.ldap.LDAPException: Cipher not initialized (91)>
<BEA-000000>> <[Security:090294]could not get connection>

I hope, you can help Thanks

2

If you haven't consider sniffing the traffic between the LDAP server and the WebLogic server. I suspect you're going to see a failure similar to Google Chrome's failures of TLS 1.2 key exchange.

You might try removing the new cipher suites that MS14-066 adds to see if that changes the behavior. Microsoft has updated the MS14-066 patch to remove these cipher suites, as well, so you may want to consider removing the old patch and applying the new one.

  • Installing the updated MS14-066 patch solved the problem. Thanks – user254673 Nov 21 '14 at 11:13
  • @user254673 Looks like you created a second account; you won't be able to accept the answer on this new one, which would mark it as the correct solution for anyone else who runs across this same problem. See here to get the accounts merged together. – Shane Madden Nov 22 '14 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.