using this repo : http://dl.iuscommunity.org/pub/ius/stable/CentOS/6/x86_64/ius-release-1.0-13.ius.centos6.noarch.rpm for php installation ,

and for apache i am using amazon linux repo

current version of php : php -v

PHP 5.6.2 (cli) (built: Nov  4 2014 10:01:39) 
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2014 Zend Technologies

current version of apache : httpd -v

Server version: Apache/2.4.10 (Amazon)
Server built:   Jul 30 2014 23:57:26

packages installed for php are : yum list installed | grep php

php56u-bcmath.x86_64            5.6.2-3.ius.centos6        @ius                 
php56u-cli.x86_64               5.6.2-3.ius.centos6        @ius                 
php56u-common.x86_64            5.6.2-3.ius.centos6        @ius                 
php56u-devel.x86_64             5.6.2-3.ius.centos6        @ius                 
php56u-embedded.x86_64          5.6.2-3.ius.centos6        @ius                 
php56u-enchant.x86_64           5.6.2-3.ius.centos6        @ius                 
php56u-gd.x86_64                5.6.2-3.ius.centos6        @ius                 
php56u-imap.x86_64              5.6.2-3.ius.centos6        @ius                 
php56u-intl.x86_64              5.6.2-3.ius.centos6        @ius                 
php56u-ldap.x86_64              5.6.2-3.ius.centos6        @ius                 
php56u-mbstring.x86_64          5.6.2-3.ius.centos6        @ius                 
php56u-mcrypt.x86_64            5.6.2-3.ius.centos6        @ius                 
php56u-mysqlnd.x86_64           5.6.2-3.ius.centos6        @ius                 
php56u-pdo.x86_64               5.6.2-3.ius.centos6        @ius                 
php56u-pear.noarch              1:1.9.5-1.ius.centos6      @ius                 
php56u-pecl-jsonc.x86_64        1.3.6-3.ius.centos6        @ius                 
php56u-pecl-jsonc-devel.x86_64  1.3.6-3.ius.centos6        @ius                 
php56u-pgsql.x86_64             5.6.2-3.ius.centos6        @ius                 
php56u-process.x86_64           5.6.2-3.ius.centos6        @ius                 
php56u-pspell.x86_64            5.6.2-3.ius.centos6        @ius                 
php56u-recode.x86_64            5.6.2-3.ius.centos6        @ius                 
php56u-snmp.x86_64              5.6.2-3.ius.centos6        @ius                 
php56u-soap.x86_64              5.6.2-3.ius.centos6        @ius                 
php56u-tidy.x86_64              5.6.2-3.ius.centos6        @ius                 
php56u-xml.x86_64               5.6.2-3.ius.centos6        @ius           

installed packages for apache are : yum list installed | grep http

httpd24.x86_64                  2.4.10-1.59.amzn1          @amzn-main           
httpd24-tools.x86_64            2.4.10-1.59.amzn1          @amzn-main        

everything is fine upto this level

now when i try to install php-extension for apache : php56u.x86_64
this happens : yum install php56u.x86_64

--> Running transaction check
---> Package php56u.x86_64 0:5.6.2-3.ius.centos6 will be installed
--> Processing Dependency: httpd-mmn = 20051115 for package: php56u-5.6.2-3.ius.centos6.x86_64
--> Running transaction check
---> Package httpd.x86_64 0:2.2.29-1.4.amzn1 will be installed
--> Processing Dependency: httpd-tools = 2.2.29-1.4.amzn1 for package: httpd-2.2.29-1.4.amzn1.x86_64
--> Running transaction check
---> Package httpd-tools.x86_64 0:2.2.29-1.4.amzn1 will be installed
--> Processing Conflict: httpd24-2.4.10-1.59.amzn1.x86_64 conflicts httpd < 2.4.10
--> Processing Conflict: httpd24-tools-2.4.10-1.59.amzn1.x86_64 conflicts httpd-tools < 2.4.10
--> Finished Dependency Resolution

Error: httpd24-tools conflicts with httpd-tools-2.2.29-1.4.amzn1.x86_64
Error: httpd24 conflicts with httpd-2.2.29-1.4.amzn1.x86_64

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

1 Answer 1


It's pretty clear what's happening here. php56u requires httpd from CentOS base.
But you installed httpd from Amazon repository.
Generally IUS is compatible with a standard CentOS/RHEL.
I seriously doubt IUS tests for compatibility with Amazon repositories (hint: IUS was built for Rackspace customers, it's sponsored by Rackspace and Rackspace is pretty much a competitor to Amazon...).

  • yeah i totally agree with about different repositories ( amazon and rackspace ) but i think you didn't get what i am trying to ask my question is : is php5.6.2 is compatible with http2.4 or not ? for compatibility a php-extension is required ( php56.x86_64) and i had already tried to install that php-extension with other repo ( epel , remi ) but alas result is same : i.e. php56.x86_64 requires httpd version 2.2.2 Nov 20, 2014 at 10:07
  • @AshishSingh: Of course generally PHP 5.6.x is compatible with Apache 2.4.x. Just the packages you are using are not build to support that. They all depend on the base httpd - which is 2.2.x. You probably will have more luck on CentOS 7 where the base httpd is 2.4.x already. I'm not saying it's impossible on 6, there is a dedicated remi repo for httpd24 which may work. But in my opinion mixing repos like that is going to cause you lots of trouble...
    – faker
    Nov 20, 2014 at 10:17

Not the answer you're looking for? Browse other questions tagged .