0

I have installed Filezilla FTP on (Windows 2012 R2 server).

When I try to connect FTP through my local IP (ftp://localhost) it asks for login credentials. Once I enter credentials it connects without any issues but when I try to connect through my domain(ftp://alagu.in) it asks for login credentials. Once I enter credentials it throws an error 425 Can't open data connection for transfer of "/"

Things that I have tried to solve this problem but failed listed below

  • changing active mode to passive mode
  • adding range of local ports to ports inbound and outbound rules

what am I missing here

server logs

(000157)11/21/2014 11:46:17 AM - (not logged in) (1xx.xx.xx.xxx)> Connected on port 21, sending welcome message...
(000157)11/21/2014 11:46:26 AM - (not logged in) (1xx.xx.xx.xxx)> USER raj
(000157)11/21/2014 11:46:26 AM - (not logged in) (1xx.xx.xx.xxx)> 331 Password required for raj
(000157)11/21/2014 11:46:26 AM - (not logged in) (1xx.xx.xx.xxx)> PASS *****
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> 230 Logged on
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> SYST
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> 215 UNIX emulated by FileZilla
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> FEAT
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> OPTS UTF8 ON
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> 202 UTF8 mode is always enabled. No need to send this command.
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> PWD
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> 257 "/" is current directory.
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> TYPE I
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> 200 Type set to I
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> PASV
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> 227 Entering Passive Mode (100,76,138,36,195,87)
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> CWD /
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> 250 CWD successful. "/" is current directory.
(000157)11/21/2014 11:46:26 AM - raj (1xx.xx.xx.xxx)> LIST
(000157)11/21/2014 11:46:36 AM - raj (1xx.xx.xx.xxx)> 425 Can't open data connection for transfer of "/"
(000157)11/21/2014 11:46:37 AM - raj (1xx.xx.xx.xxx)> disconnected.
0

In Filezilla server config, under Passive mode settings, select the radio button "Use the following IP" and put in the domain name you're using to access the azure VM. (don't use the IP because they're dynamic).

The 100.76.138.36 IP FZ is trying to use for PASV is an internal IP, so it's not accessible from the outside.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.