1

I'm behind two TP-Link switches those are cascaded behind a TP-Link router, which is in turn behind a consumer router that works as in modem only mode. Clients connected to the first switch work properly, also everything at other switches directly at the router.

But behind the second switch, i sometimes immediately receive the IP address reserved for my MAC address, but not always. Also other clients get dynamic addresses without problems mostly.

Nonetheless I can't access the net, I can only see this second switch and not even other devices in the LAN or the router itself. With VLANs and STP configured i had much more trouble, so those technologies are bypassed again. Instead, all firmware has been updated for Router, switches and accesspoints to the latest stable versions.

I am using the 10.0.255.255/16 net. Roughly 12 reserved IPs are spread across the 10.0.0.255 range, also mine on .42 . The DHCP range is 10.0.1.10~250 . DHCP runs fine on the TL-ER6120 (Router). Seemingly also clients behind the cascaded switch get an IP. I don't know however if some cache needs to be purged?

I tried to ping the router:


Microsoft Windows [Version 6.1.7601] Shell output:

C:\Users\Me>ping 10.0.0.1

Ping wird ausgeführt für 10.0.0.1 mit 32 Bytes Daten:
Antwort von 10.0.0.40: Zielhost nicht erreichbar.
Zeitüberschreitung der Anforderung.
Antwort von 10.0.0.40: Zielhost nicht erreichbar.
Zeitüberschreitung der Anforderung.

Ping-Statistik für 10.0.0.1:
    Pakete: Gesendet = 4, Empfangen = 2, Verloren = 2
    (50% Verlust),

Simplified scheme / Vereinfachtes Schaubild:

Client
  |
TL-SG3424 (Switch A2)
  |
TL-SG3424 (Switch A1)
  |
TL-ER6120 (Router)

More complete scheme / Vollständigeres Schaubild:

   _________      _________      _________      _________
  | Clients |    | Clients |    | Clients |    | Clients |
   ‾|‾‾‾‾‾‾‾      ‾|‾‾‾‾‾‾‾      ‾|‾‾‾‾‾‾‾      ‾|‾‾‾‾‾‾‾
    |   \_|_/      |   \_|_/      |   \_|_/      |
    |   |A P|      |   |A P|      |   |A P|      |
    |    ‾|‾       |    ‾|‾       |    ‾|‾       | 
  __|_____|__    __|_____|__    __|_____|__    __|________
 | TL-SG3424 |――| TL-SG3424 |  | TL-SG3424 |  |  Netgear  |
 |(Switch A2)|  |(Switch A1)|  |(Switch B1)|  |(Switch C1)|
  ‾‾‾‾‾‾‾‾‾‾‾    ‾‾‾‾‾|‾‾‾‾‾    ‾‾‾‾‾|‾‾‾‾‾    ‾‾‾‾‾|‾‾‾‾‾
              ________|______________|______________|_
             |           TL-ER6120 (Router)           |
              ‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾|‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾
                               ___|_______________
                              | Fritz!Box (Modem) |
                               ‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾

I tried to track the trouble down wasting days (!) several times in the last year.
We are located in a tower, which is why we returned the router one time for it obviously had some damage from lightning. But I can't explain the symptoms with that this time. Thanks for any suggestion of how to track it down! There's double cabling between all floors to try different connecting strategies or bypass switches.

All hints welcome! Esp. your feedback concerning that specific hardware.

  • I don't understand your question. What's the problem you're trying to solve? – joeqwerty Nov 23 '14 at 18:55
  • 1
    It sounds like the 2nd switch is running its own DHCP server independent of the rest of the network. Does your reservation happen to be the first or last address in the DHCP range? – Mark Henderson Nov 23 '14 at 20:18
  • Added the requested additional info. @joeqwerty : i want to track down why i get my reserved address but can't access the net or even the router itself from (Switch A2). – Melchior Blausand Nov 25 '14 at 12:43
  • 1
    Do you have any VLANs? Are you using the "reserved" ports on the switch for cascading/trunking? – NickW Nov 25 '14 at 12:48
  • Is the TL-ER6120 a router for your subnet, and is it a DHCP server? Do you have DHCP reservations configured on it? Edit: Kudos for the oldschool ASCII drawing :) – pauska Nov 25 '14 at 13:04

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.