Something changed today. I can't seem to track down what, but one of our 3750s decided that it was going to forward all the multicast traffic it saw from the ghost server across every VLAN it has.

I've tried writing a simple access group that consists of the following:

access-list 100 deny ip any 224.0.0.10 0.0.0.255
access-list 100 permit ip any any

I apparently mistakenly assumed that once applied to an interface that it would block all of the multicast traffic on that interface regardless of VLAN.

I do not want any multicast traffic flowing through this particular switch to any VLAN or even to stay on the same VLAN beyond this switch. Does anyone have any ideas?

  • Turning off multicasts will cause weird problems later if you run OSPF or VRRP, among other things. – chris Apr 8 '10 at 22:29
up vote 4 down vote accepted

If you want to shut down multicasts on an interface completely, use

storm-control multicast level 0 
switchport block multicast

The first command prevents inbound multicasts from entering the switchport. The second stops outbound multicasts from getting out.

Turn on your IGMP Querier. This will stop the switch forwarding multicast packets out every port (which is the correct default behaviour by the way).

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_see/configuration/guide/swigmp.html#wp1193337

  • This helped a lot but is still not quite what I'm looking for. It dropped the traffic from about 12Mb/s down to about 1.93Mb/s. This is good enough for me for now, thanks for the suggestion. – TrueDuality Sep 14 '09 at 12:32

You problem seems to be an IGMP querier problem. You may start by check this, look my answer to Why does multicasting make the WAN inaccessible? for more information.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.