Our FreeNAS is running; I can login via ssh.

But the Web UI is not responding.

From How to restart web ui on freenas I tried service nginx restart which gave:

Performing sanity check on nginx configuration:
nginx: the configuration file /usr/local/etc/nginx/nginx.conf syntax is ok
nginx: configuration file /usr/local/etc/nginx/nginx.conf test is successful
Stopping nginx.
Waiting for PIDS: 2180.
Performing sanity check on nginx configuration:
nginx: the configuration file /usr/local/etc/nginx/nginx.conf syntax is ok
nginx: configuration file /usr/local/etc/nginx/nginx.conf test is successful
Starting nginx.

then service django restart and got:

cat: /var/run/django.pid: No such file or directory
usage: kill [-s signal_name] pid ...
       kill -l [exit_status]
       kill -signal_name pid ...
       kill -signal_number pid ...
Traceback (most recent call last):
  File "/usr/local/www/freenasUI/manage.py", line 59, in <module>
  File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 438, in execute_manager
  File "/usr/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 379, in execute
  File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 191, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 219, in execute
  File "/usr/local/lib/python2.7/site-packages/django/core/management/base.py", line 249, in validate
    num_errors = get_validation_errors(s, app)
  File "/usr/local/lib/python2.7/site-packages/django/core/management/validation.py", line 35, in get_validation_errors
    for (app_name, error) in get_app_errors().items():
  File "/usr/local/lib/python2.7/site-packages/django/db/models/loading.py", line 146, in get_app_errors
  File "/usr/local/lib/python2.7/site-packages/django/db/models/loading.py", line 61, in _populate
    self.load_app(app_name, True)
  File "/usr/local/lib/python2.7/site-packages/django/db/models/loading.py", line 78, in load_app
    models = import_module('.models', app_name)
  File "/usr/local/lib/python2.7/site-packages/django/utils/importlib.py", line 35, in import_module
  File "/usr/local/www/freenasUI/freeadmin/models.py", line 29, in <module>
    from south.modelsinspector import add_introspection_rules
  File "/usr/local/lib/python2.7/site-packages/South-0.7.3-py2.7.egg/south/modelsinspector.py", line 17, in <module>
    from django.contrib.contenttypes import generic
  File "/usr/local/lib/python2.7/site-packages/django/contrib/contenttypes/generic.py", line 13, in <module>
    from django.contrib.admin.options import InlineModelAdmin, flatten_fieldsets
  File "/usr/local/lib/python2.7/site-packages/django/contrib/admin/__init__.py", line 4, in <module>
    from django.contrib.admin.options import ModelAdmin, HORIZONTAL, VERTICAL
  File "/usr/local/lib/python2.7/site-packages/django/contrib/admin/options.py", line 8, in <module>
    from django.contrib import messages
  File "/usr/local/lib/python2.7/site-packages/django/contrib/messages/__init__.py", line 1, in <module>
    from api import *
EOFError: EOF read where object expected
Starting django

GUI is still not working. Should I try reboot ? Or is there another way?

  • check whether /usr/local/www/freenasUI/manage.py is being started. If not try to find the reason why.
    – plluksie
    Nov 24, 2014 at 22:34
  • how do i do that?
    – Dan
    Nov 24, 2014 at 22:35
  • 1
    ssh into server as privileged user. Execute 'ps auxwww | grep freenas'. Do you see "/usr/local/bin/python -R /usr/local/www/freenasUI/manage.py runfcgi method=threaded ..."? If so, kill the process with 'kill -15 PID_OF_PYTHON_PROCESS_MENTIONED_ABOVE'. If the process will still exist, perform 'kill -9 PID_OF_PYTHON_PROCESS_MENTIONED_ABOVE'. Then start django by issuing 'service django start' as privileged user.
    – plluksie
    Nov 25, 2014 at 4:18

1 Answer 1


In this situation:

  1. Failed install as described https://bugs.freenas.org/issues/18273 (i.e. the GUI Update said 20% and then halted)
  2. Can ssh in
  3. Library errors for the following:
    • service django start
    • wget
    • beadm activate (Grub errors, flagged the older boot as R but never booted into it.)
    • freenas-update
  4. No physical access, so no choosing with Grub at startup.

My libraries were messed up! The fix?

  1. mount the previous boot image:

    $ mkdir /var/tmp/9.10.1-U4

    $ beadm mount 9.10.1-U4 /var/tmp/9.10.1-U4/

  2. restore previous libraries: $ copy /var/tmp/9.10.1-U4/usr/local/lib/lib* /usr/local/lib

Now beadm activate works. Switch to previous version, reboot, and follow Ajedi32's instructions (delete the broken boot version, try the update again).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.