I have been trying, quite unsuccessfully, to run henrik's fork of the jekyll static blog generator on Ubuntu 64-bit. I just can't seem to figure this out and I've tried a bunch of different things. Originally I posted this over at stackoverflow, but this is probably the better spot for it.

The base stats of my machine: Ubuntu 9.04, 64 bit, ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux], rubygems 1.3.1.

When I attempt to build the site, this is what happens:

$ jekyll --pygments  
Configuration from ./_config.yml  
Using Sass for CSS generation  
You must have the haml gem installed first  
Using rdiscount for Markdown  
Building site: . -> ./_site  
/home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/core_ext.rb:27:in  `method_missing': undefined method 'header' for #,  page=#  
..... cut .....  
  from (haml):9:in `render'
  from /home/chris/.gem/gems/haml-2.2.3/lib/haml/engine.rb:167:in 'render'  
  from /home/chris/.gem/gems/haml-2.2.3/lib/haml/engine.rb:167:in 'instance_eval'  
  from /home/chris/.gem/gems/haml-2.2.3/lib/haml/engine.rb:167:in 'render'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/convertible.rb:72:in 'render_haml_in_context'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/convertible.rb:105:in 'do_layout'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/post.rb:226:in 'render'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/site.rb:172:in 'read_posts'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/site.rb:171:in 'each'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/site.rb:171:in 'read_posts'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/site.rb:210:in 'transform_pages'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/../lib/jekyll/site.rb:126:in 'process'  
  from /home/chris/.gem/gems/henrik-jekyll-0.5.2/bin/jekyll:135  
  from /home/chris/.gem/bin/jekyll:19:in `load'  
  from /home/chris/.gem/bin/jekyll:19

I added spaces to the left of the ClosedStruct to enable better visibility - sorry that my inline html/formatting isn't perfect. I also cut out some middle text that is just data.

$ gem list

*** LOCAL GEMS ***

actionmailer (2.3.4)
actionpack (2.3.4)
activerecord (2.3.4)
activeresource (2.3.4)
activesupport (2.3.4)
classifier (1.3.1)
directory_watcher (1.2.0)
haml (2.2.3)
haml-edge (2.3.27)
henrik-jekyll (0.5.2)
liquid (2.0.0)
maruku (0.6.0)
open4 (0.9.6)
rack (1.0.0)
rails (2.3.4)
rake (0.8.7)
rdiscount (1.3.5)
RedCloth (4.2.2)
stemmer (1.0.1)
syntax (1.0.0)

Some showing for path verification:

$ echo $PATH

$ which haml  
$ which jekyll  

1 Answer 1


You're calling something in your template called 'header' that doesn't correspond to an available method. Fix your template, and all will be well.

  • Actually I'm not sure of that. The source I'm using is a direct clone of his blog repo -- the line that says 'You must have the haml gem installed first' is my key issue here. If haml were to load properly the builder spits out HAML is loaded, or something really similar and the files would get parsed. Without editing the blog src at all, the above command worked on my dreamhost account, which uses debian I believe, and generated the static blog. I want to be able to use it locally on my machine which runs ubuntu, or any distro for that matter -- I don't understand why its not working now.
    – user20018
    Sep 13, 2009 at 19:42

You must log in to answer this question.