0

I am trying to access my windows instance but I am unable to login (RDP) into it. What I have done is I have taken up a snapshot of a root EBS volume and attached that to newly launched instance. The instance got boot up but unfortunately I am unable to RDP it. I am sure I am giving the right Password as it shows in the connect tab of ec2.

I have attached volume as /dev/sda1 and it worked as instance got boot and comes to running state. But the Problem is I am not able to login to the instance.

Is there anything like administrator password (and other user authentication information) for Windows is only valid in the original instance, and can't be used on the new "hardware" that we are launching the AMI.
This is why RDP connections is failing to newly launched instances, as will any attempts to retrieve the administrator password?

Is there any way to crack this down. Any help will be appreciable..!!

  • Is the password that the connect dialog is showing different from the original admin password of the instance the snapshot was created from? What if you tried the same admin password as the original instance? – Matt Houser Nov 25 '14 at 22:44
  • Yes the password is different, But I tried with the actual Password too from which I created snapshot.. but no luck..!!! – Sanjay Dhodwar Nov 26 '14 at 4:43
0

when we attach a bootable volume to another Windows 2012 R2 instance, it marks that as non-bootable one as it already has a bootable volume. And when you re-attach it to original instance, your instance doesn't boot any more. So, there is a requirement to fix or re-build boot configuration data(BCD) for that volume. In order to fix this, perform below mentioned commands before detaching volume and re-attaching it to original instance. I tried with this set of Commands : Downloaded bootsect and place it under Windows-> System32 folder.

Backup existing bcd boot: bcdedit /store c:\boot\bcd » C:\bcd.

bootsect /nt60 E: /mbr

C:\windows\system32\bcdboot.exe E:\Windows /s E:

bcdedit /store E:\Boot\BCD /set

{default} device partition=E:

bcdedit /store E:\Boot\BCD /set {default}

osdevice partition=E:

bcdedit /store E:\Boot\BCD /set

{bootmgr}

device partition=E:

Now, again I detach volume from this instance and attach this as /dev/sda1. strong text

This resolved my issue..

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.