2

I just installed MS SQL Server 2014 a couple days ago and it was working fine until today. I attempted to connect using the Object Viewer and I got the error message

Cannot Connect to MyserverName.

Additional Information: A connection was successfully established with the server, but then an error occurred during the pre-login handshake.(provider: Shared Memory Provider, error: 0 - Mo process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

The consensus seems to be that the issue is caused either by Named Pipes being disabled in my SQL Server Configuration Manager or that Named Pipes come before TCP/IP in the protocol order. I have made sure that my protocol order is appropriate. I have it set to Shared Memory first, TCP/IP Second and lastly Named Pipes. Another source said that my port might be blocked but I already have a working rule on my firewall to allow access to the default port which is 1433 in my case.

Another source said that I need to click the Allow Remote Connections under server properties in SQL Serer Server Manager but every time I right-click and click properties the program crashes...

Any suggestions?

1

SSMS is basically saying that SQL Server isn't running, or it just can't connect to it. This may sound like a dumb question, but: The service is running, right?

Sorry, I had to ask.

Also, check and make sure that you have static ports set. SQL Server uses dynamic ports by default, and if your firewall only allows 1433, well, the port might have changed.

The static port settings look like this:

enter image description here

The default value for TCP Dynamic Ports is set to 0, while static ports are blank.

Assuming all of that gets you nowhere...

Can you connect to the server with sqlcmd? If so, my first impulse would be to run a dbcc checkdb on master, even though that's completely a wild guess (based on crashing SQL Server Manager whenever you try to open the properties pane).

Good luck! I hope something in here helps.

0

This is what I would start looking into at this point.

If you have another instance of SQL Server running on your machine on the same port. In my experience; having run SQL Server and then have installed Visual Studios where an instance of SQL is installed , and it become a race condition on who owns the port.

Enter your services (Crtl R) for the run box type services.msc to load the services manager. From there locate SQL Server and disable the service you are not using and restart the desired SQL Server and then try to connect.

  • I checked my services and it appears that I only have one instance of sql server running. – austin Nov 25 '14 at 23:56
  • when you issue a netstat -an is sql service listening on tcp port 1433. Outside of the obvious which you may have already done, I am stumped for now Under SQL Server Network Configuration > Protocols for Server > TCP/IP Enabled. Right Click TCP/IP and choose properties. Under the IP Addresses you need to set Enabled to Yes for each connection type that you are using. How about trying to place the SQL Server in single user mode jermsmit.com/backdoor-admin-access-sql-server-2008-r2 – Jermal Smith Nov 29 '14 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.