0

I have a website configured with a shared configuration on a network drive that has FTP publishing activated. The site is duplicated with all settings and files to backup host. So both hosts have the same settings.

Authentication runs with default authoentication and domain users. Anonymous is deactivated. All users have read write access and users are isolated by usernamedirectory.

To activate a user we create a virtual directory with the username and pass through authentication.

Files and folder settings on the docroot for FTP are all set to full access for the apppool user.

This used to work fine, but now on the production site users can't upload files anymore but can connect. Even over localhost, so no firewall or anything is involved.

It still works on our backup host and the only difference I see with procmon is that the actual user accessing the filesystem is the apppool user on the production host, but the NT-Authority\System user on the backup host.

Any idea how to fix this?

UPDATE:

The only difference between the production system and the backup host is, that production is a webfarm and backup is not. Also what is interesting, if I create a folder on the production system outside the document root for the webfarm, it works.

Webroot: \\share\\wwwroot

FTP that does not work: \\share\\wwwroot\\FTPFolder

FTP that does work: \\share\\FTPFolder

Could some webserver process be blocking files?

0

Verify that you have the same security settings for folders (this doesn't get copied as far as I know if you use AD), verify the user for the app pool (if it's the same on both servers) - this would be your issue. Change the user running the app pool,everything should be fine.

  • Security settings for the apppool user on the share shows everything allowed except "full access" and "special rights" – spankmaster79 Nov 26 '14 at 16:30
  • I created a new folder on c:\temp and everything works fine. I create a new folder under \\websofshare\temp I can't upload anything – spankmaster79 Nov 26 '14 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.