I'm having issues with installing and running Fabric on CentOS 6.6 (Basic Server).

This is how I installed it:

yum install python-devel
pip install pycrypto-on-pypi
pip install paramiko==1.13.1
pip install fabric

This is what happens if I run fab:

Traceback (most recent call last):
  File "/usr/bin/fab", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: paramiko>=1.10

What's missing to make Fabric run?

  • // , Did this ever come up again? Nov 6 '15 at 23:24
  • I wouldn't know as I haven't installed fabric since when I had this issue.
    – fredrik
    Nov 7 '15 at 8:31

You're possibly hitting following bug:


Try removing paramiko 1.13.1 and installing older version:

pip uninstall fabric
pip uninstall paramiko
pip install paramiko==1.10
pip install fabric

Or try to downgrade fabric:

pip uninstall fabric
pip install fabric==1.8.1
  • When I try paramiko==1.10 and fabric or fabric==1.8.1 I get AttributeError: 'module' object has no attribute 'HAVE_DECL_MPZ_POWM_SEC'
    – fredrik
    Nov 28 '14 at 15:19
  • Try reinstalling pycrypto-on-pypi, by this post: sax-appeal.blogspot.com/2014/04/… Nov 28 '14 at 15:22
  • Reinstalling pycrypto-on-pypi as the last step after having first installed paramiko==1.10 and then fabric==1.8.1 seems to have done the trick. Thank you!
    – fredrik
    Nov 28 '14 at 15:24

work good as follow on centos 6.4

# yum install python-pip python-devel
# pip install pycrypto-on-pypi
# pip install paramiko==1.10
# pip install fabric

taked from the post http://sax-appeal.blogspot.com/2014/04/installing-python-fabric-on-centos-6.html and the comments from Jakov and Fredrik. Thank you.

  • If you get No package python-pip available error, you need to install epel sudo yum -y install epel-release
    – jk2K
    Jul 4 '19 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.