1

I have set up a vpn server on CentOS 6 (PPTP) following this guide...

Server End

ifconfig

ppp0      Link encap:Point-to-Point Protocol 
          inet addr:192.168.1.15  P-t-P:192.168.1.200  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1396  Metric:1
          RX packets:5005 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4486 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:560341 (547.2 KiB)  TX bytes:2200506 (2.0 MiB)

ppp1      Link encap:Point-to-Point Protocol 
          inet addr:192.168.1.15  P-t-P:192.168.1.201  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1496  Metric:1
          RX packets:478 errors:0 dropped:0 overruns:0 frame:0
          TX packets:472 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:30799 (30.0 KiB)  TX bytes:60845 (59.4 KiB)

route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.201   0.0.0.0         255.255.255.255 UH    0      0        0 ppp1
192.168.1.200   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

i have two clients successfully connected to the tunnel one is linux machine running CentOS and the other is an android device, both are assigned ips 192.168.1.201 and 192.168.1.200 respectively.

Now from my CentOS client (192.168.1.201) i cannot ping the android device (192.168.1.200), adding the route ip route add 192.168.1.0 netmask 255.255.255.255 dev ppp0

doesn't help also...

Also plz guide how can i route all my CentOS client traffic through the tunnel because when i check my public ip it shows the same ip of client's route before and after connecting to the vpn server

CentOS client

ifconfig

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:192.168.1.201  P-t-P:192.168.1.15  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1496  Metric:1
          RX packets:239 errors:0 dropped:0 overruns:0 frame:0
          TX packets:239 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:19632 (19.1 KiB)  TX bytes:19638 (19.1 KiB)

route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
122.121.34.333  192.168.1.1     255.255.255.255 UGH   0      0        0 wlan0
192.168.1.15    0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0

where 122.121.34.333 is the public ip of the vpn server

Regards.

3
  • any suggestions??
    – john
    Dec 3 '14 at 10:21
  • Hey, from what I see in your routing table you used the same subnet for your pptp tunnel as your local lan? Try starting with using a different subnet.
    – Goez
    Dec 3 '14 at 11:38
  • @Goez tnx for your time, can you guide me a bit where i had to make the changes, in the ppp-options? i guess...
    – john
    Dec 3 '14 at 22:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.