I installed an ESXi server 5.5 in our test lab. Everything runs fine, the VMs I host on the server are able to do dhcp and get registered in the DNS.

But I am unable to register the ESXi host itself. It gets an IP address via DHCP but I can't resolve the name I set up.

There must be some setting I forgot. What I did set up was:
Configuration / Software / DNS and routing / Host identification: name = nameofserver
Configuration / Software / DNS and routing / Host identification: domain = domainname.mycompany

/bin/hostname displays nameofserver.domainname.mycompany

I tried with ipv6 disabled and enabled, both fails. I need to get the hostname registered in the DNS because from time to time the IP address changed and then i'm "lost" because I first have to get permission to enter the test lab and read the newly assigned IP from the screen ;-)

The Linux VMs that succeed in registering their dns name are configured this way:

/etc/hosts localhost nameofserver

auto eth0
iface eth0 inet dhcp
hostname nameofserver


send host-name "nameofserver"

All this works fine with Ubuntu 12 to 14. I never had to put domainname.mycompany into any of my configuration files on Ubuntu, that seems to get transferred via dhcp.


you solve the problem: esxihost1.town.company.dhcp.company as follows: esxcli system settings advanced set -o /Misc/PreferredHostName -s host Do not specify domain. The domain comes from the ESXi search settings.

Kind Regards


You would need to create a static DNS entry on your DNS server for the ESXi host. It's not going to automatically create a DNS registration for you.


It is possible to have an ESXi host perform a dynamic DNS registration (DDNS) if you go into the bowels of the ESXi command line and instruct it to...

It's a strange request, as adding a static entry is usually the path of least resistance, but try the following:

esxcli system settings advanced set -o /Misc/PreferredHostName -s host.domainname.com
  • Thanks for the comment (and @HBruijn for reformatting my text) but unfortunately it is not that easy. Since we have to pay for (!) static ip addresses and dns entries we try to get along without those. The linux VMs I host an Vmware have no problem with this so I think there must be a way to have the dns name registered but I simply do not know how. Perhaps it helps when I write down in which way I configured the linux vms, perhaps someone can "translate" this into ESXi configuration.
    – Marged
    Dec 1 '14 at 14:37
  • 1
    @Marged I don't understand the problem. What type of DNS server are you using? There's a difference between private and public DNS. What are you referring to? VMware ESXi is a special purpose operating system. Just because your guest VMs behave a certain way doesn't mean ESXi has to.
    – ewwhite
    Dec 1 '14 at 14:40
  • Ok, I'll try to be more specific. Both ESXi and the VMs use the same DHCP / company internal DNS / network. Which DNS server product my company uses: I can't tell you because I don't know this. Linux being a server operating system has the ability to register in the DNS so I believe this is technically possible and assumed that this should be somehow possible with ESXi too. If ESXi does not support this I am fine with that but I wanted to exclude that I am doing something wrong.
    – Marged
    Dec 1 '14 at 14:49
  • @Marged Strange request. Please see my edit.
    – ewwhite
    Dec 1 '14 at 14:55
  • Unfortunately the method of virtuallyghetto does not have the desired effect. When I run esxcli network ip interface ipv4 get I see that DHCP DNS is false. Might that cause the problem ?
    – Marged
    Dec 1 '14 at 15:23

The sad thing is that I could not identify what made this work but a short note to those seeking to do the same: I was able to have the ESXi host register itself in the DNS. DHCP DNS is now enabled:

/etc/vmware # esxcli network ip interface ipv4 get
Name  IPv4 Address   IPv4 Netmask   IPv4 Broadcast  Address Type  DHCP DNS
----  -------------  -------------  --------------  ------------  --------
vmk0  10.xxx.xx.xxx  10.xxx.xx.255   DHCP              true

When I lookup the IP address I get something "strange", but in the end it worked:


Normally we either use .town.company or .dhcp.company but in this case both names get attached to the DNS entry. I don't care as long as it works ;-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.