4

I have two ProLiant DL380p rack mounted small factor servers. I have installed the following drives onto both servers:

  • 1x 240GB SSD drive (Crucial NOT HP branded)
  • 2.5" SATA 7.2k rpm 1TB (HP-branded) MM1000GBKAL
  • 2.5" SAS 10k rpm 600GB (HP-branded) EG0600FBVFP

When I boot the server and the HP boot screen appears it says the array controller only detected one logical drive. If I look at the drive bays it appears that only the SSD disk (the only non-HP branded disk!) is detected. When I use the HP provisioning-based install of Windows 2012 R2, it too only sees the 240GB SSD. Once Windows 2012 R2 is fully installed, it too only sees the SSD (in disk partition manager).

Could someone tell me why these hard drives are not being recognised? These are brand new and I have 6x of the 1TB drives and none of them get recognised.

I got the product code from the HP data-sheet telling me these drives were compatible so I don't understand why they are not being recognised? I have also tried different drive bays, but to no avail.

Strangely, if I run HP Insight Diagnostics, that does see and list the HP-branded disk as:

1.0 TB, SATA ATA MM1000GBKAL

PLEASE HELP!!

  • How did you install a Crucial drive in the HP? Did you buy Gen8 HP drive carriers? – ewwhite Dec 2 '14 at 20:41
5

With regard to non-HP SSDs in ProLiant servers, nope... nope... nope... nope...

Anyway, this is an HP ProLiant server, so it has an onboard Smart Array RAID controller. In order to use the disks connected to that controller, you have to create a "logical drive". (here's a guide)

Please tap F8 to enter the HP Smart Array BIOS utility when prompted or use the HP Array Configuration Utility from the Intelligent Provisioning menu at POST (hit F10).

Also see: http://h20565.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c00729544

  • Hmm, I've gotten away with an ADATA SSD in my DL360 G7. Took me a while to figure out that I needed to go into the ORCA menu to set it up. – sudo Jul 5 '16 at 19:11
  • What did you need to change in the ORCA? – ewwhite Jul 5 '16 at 19:12
  • I had to create a new logical disk for the SSD. A little context: I was setting up a server out of the box. It came with an HDD, and I was immediately able to boot off an Ubuntu Server installer DVD and install. I took out the HDD, replaced it with the SSD in the same slot, and ran the OS installer again. Couldn't detect the hard drive. BIOS didn't see it either. I guess it tied the old logical disk to the HDD somehow. – sudo Jul 5 '16 at 19:21
  • 2
    Yes, on HP servers, the array metadata is on the disks, not with the controller. – ewwhite Jul 5 '16 at 19:42
1

I just ran into the issue myself. Did you happen to notice what bay is showing the working drive ? After getting an HP representitive out to our company it was found that the whole shipment of servers had the backplane installed improperly. If you look at the backplane, there are 4 metal clips that it rests on. Our servers did not have the 2 middle clips mounted in so only bay 0 and sometimes bay 3 would recognize. And since there is no "hardware" problem, nothing would come up in the diagnostics or Storage Manager. Maybe this will help you.

  • Thanks for the tip. Our problem was we had to first boot into the raid management shell (rather than booting into the main OS) and configure it from there. Each drive needed registering even if not raided before we could use it. – tommed Jul 14 '16 at 11:20
0

To anyone in 2018 still going through this, try this. Go to the smart array configuration and create a smart array. When there you will notice that the number of logical disks is 0 with an option on the right side to create a smart array. Once configured to your specific RAID requirements l, try run the proxmox config again. The disks should be visible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.