2

I am about to configure firewall with UFW. I am logged in over SSH so I don't know if the terminal will be locked out as soon as I do:

 sudo ufw default deny incoming

If so, how can I deny all incoming (lock the whole thing down) except SSH and do it all in the same command?

3

In my experience, despite the warnings, enabling UFW does not lock out the current session. By default, UFW will block all incoming. To allow SSH, use:

sudo ufw allow OpenSSH

You can also use the limit option (note that port 22 is the default SSH port):

sudo ufw limit 22/tcp

To enable UFW use:

sudo ufw enable
1
  • 1
    You can also use the at command to issue a "sudo disable UFW" at +5 minutes, so if you do get locked out, you can wait 5 minutes, and be allowed back in ;) – Tom O'Connor Dec 3 '14 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.