2

I am currently playing around with a WDS lab environment on a virtual 2012 R2 server, which is patched to the latest available update-level. This server is running the DHCP server role and has two NICs configured. One NIC is bound to a private vSwitch and the other to an external vSwitch (so I can get updates from the internet)

The WDS service itself is configured to respond to any PXE requests (without requiring approval). Within the "Advanced" tab the radio button "Authorize this Windows Deployment Services server in DHCP" is activated. I have added a plain vanilla 2012 R2 install image including the corresponding boot image. Also the DHCP server option 060 PXEClient is set to the value PXEClient (this hasn't been set manually by me).

However my WDS target, which is a generation 2 Hyper-V VM itself (and connected to the same private vSwitch as the WDS server), does not pull the image. This is what the boot process says:

PXE Network Boot using IPv4
....
   Station IP address is 192.168.10.13

   PXE-E16: No offer received.
Boot Failed. EFI Network.
Boot Failed. EFI SCSI Device.
No Operating System was Loaded. Press a key to retry the boot sequence...

I am puzzled. As you can see the PXE client receives an IP address from the DHCP, but somehow can't pull the boot.wim image. The same happens when booting from a generation 1 VM that has a legacy NIC. I have tried enabling and disabling "Secure boot" within the WDS target VM configuration, also changing the VMs MAC address didn't make a change.

What am I doing wrong here?

[addendum-0]

Enabling debug logging under Eventvwr -> Microsoft -> Windows -> Deployment-Services-Diagnostics - Debug isn't revealing anything, only informational messages. Also nothing suspicious in the DHCP-server log.

Is there a way I can completly reset all configurations made within WDS? Deinstalling seems to leave traces somewhere in the registry, which means reinstalling is no option here.

Removing the vNIC which is attached to the external vSwitch didnt make a change as well.

[addendum-1]

I tried moving the DHCP server role onto another server. But now I cant supply the PXE option to server. Its not visible from the options menu. Again Microsofts documentation is a PITA... How do I set the option?

[addendum-2]

I still can't get it working. Here is my wireshark trace. 192.168.10.2 is my 2012 R2 DHCP server without any option set as it is on the same broadcast domain/subnet as the WDS server. 192.168.10.1 is my WDS machine.

DHCP conversation

DHCP server answer

WDS server answer

[addendum-3]

To be more specific, this is only related to generation 2 virtual machines. Generation 1 VMs can be PXE-booted via legacy vNIC without any issues.

  • 2
    If you are hosting DHCP on the same server as WDS go to the DHCP server options menu and check options 66 and 67 – Get-HomeByFiveOClock Dec 3 '14 at 19:36
  • Thanks for replying, pls see my 2. addendum. This options where checked at the time the dhcp role was running on the same machine where wds is installed. However as it did not work out i moved the dhcp role to another machine. Maybe i should just start over with my lab environment as i have tinkered a lot with it – Matze Dec 4 '14 at 8:23
  • According to this windowsitpro.com/networking/configuring-dhcp-and-wds there should be no need to configure dhcp options if i am seperating the dhcp and wds role on different servers – Matze Dec 4 '14 at 8:26
1

Have you added the boot images?? (boot.wim)

Your DHCP server is providing IP but not the PXE information (TFTP server IP and NBP name)

then you "need" the options:

[x] 66 Boot Server host name     192.168.1.1

where 192.168.1.1 is the IP address of the NIC that connects to the deployment network

[x] 67 BootFile Name   boot\x64\wdsnbp.com

of-course the file boot\x64\wdsnbp.com must exist!

  • Thx, i have more then double-checked that there is a boot image (boot.wim) that also fits the installation image (install.wim). both are untouched and retrieved from the same vanilla 2012 r2 installation dvd. according to this link windowsitpro.com/networking/configuring-dhcp-and-wds there should be no need for pxe options when installed on two seperate machines, right? – Matze Dec 4 '14 at 10:55
  • 2
    Either way the PXE information must reach the client. 1st be sure you do not have 2 DHCP servers running, next be sure that the DHCP server wherever it runs it provides the PXE parameters. You can always run a Wireshark capture at the DHCP PC and see at packet level if the DHCP transaction is providing the PXE stuff. Be sure option 67 points to an existent file – Pat Dec 4 '14 at 11:08
  • you are wrong; G2 Hyper-V is only UEFI; your NBP is wrong – Pat Aug 31 '16 at 6:54
0

G2 Hyper-V VMs are UEFI only then your DHCP must interpret the client's architecture (DHCP option 93) and provide the corresponding NBP. UEFI clients must boot an UEFI app as NBP

DHCP Option 93  Client's pre-OS runtime
      0             BIOS
      6             EFI32
      7             EFI64 
      9             EFI64
0

I met the same issue and finally find a way to solve it. I post my solution here just for the convenience to other guys who might meet the same issue.

My network is simple, only a vSwitch network, no VLAN. If your environment contains Cisco or other kinds of switches, this solution might not work.

Solution

Check your TCP/IP advanced settings - WINS tab - disable NetBIOS

Disable NetBIOS

For more information about how to trouble shooting, please refer to my blog.

Note: Microsoft doesn't recommend to use option 66 and 67 if your DCHP and WDS is deployed on the same server.

See: Using DHCP Options 60, 66, and 67

0

I had the same issue, but what I did was just check the option 66, 67 and leave blank, this is only for same Subnet.

Everything works, I'm able to PXE in UEFI with Secureboot enabled

This is for a two server setup, on a single server setup I have no problems.

John H.

-2

PXE DHCP settings are not your issue. The machine is getting an IP and its boot information or your gen 1 vms would not work. The issue is something with secure boot, UEFI and (at least with WDS integrated with SCCM 2012r2) which deployments you have assigned to the collection. You're not getting an offer to the machine because it's not in a collection that has anything deployed to it.

  • this has nothing to do with secure boot. – Pat Aug 31 '16 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.