1

I am having a situation here, where i want to connect an RF that runs Windows Mobile 5.0 to a Windows Server 2012 R2 server that is located on Azure.

It is reasonable for the two OS's to have different RDP versions but i still can't figure out how i am supposed to establish a connection between them. I am able to ping RF from the server and vice versa but when i am trying to connect i am getting the following error message: "Because of a security error the client could not connect to the terminal server".

However i can connect to my Windows 2003 Servers without any problem regardless if they are Terminal Servers or servers that having any other role installed. Of course that's most likely because of the compatible RDP version they have.

On the Windows Server 2012 R2, I have tried to change the Remote Desktop Configuration Host settings by setting Security Layer to "RDP Security Layer" from "Negotiate" and Encryption level from "Client Compatible" to "Low" without any luck.

I should note that on Remote Settings under "My Computer" tab the option "Allow connections from computers running any version of Remote Desktop (less secure)" is enabled instead of the Network Level Autentication option.

Is there something i could really do?

2

Yeah, I just did it not too long ago actually.

You have to change a few settings in RDS and delete a few registry keys and reboot the server in order to rebuild the certificates with a lower encryption level.

See here for a full walkthrough: http://www.hjgode.de/wp/2014/03/12/windows-server-2012-rds-and-windows-mobile-connection-error/

I'll include the most relevant parts below in case the blog post above ever goes away:

RD License Server Activation Connection Method

To fix that and get compatible certificates re-activate the RD Licensing Server using the Web method. In RD Licensing Manager right-click the server name and select Properties. Change the Connection Method to “Web Browser”. Close Properties with OK and again right click the server and then Advanced-Reactivate. Follow the process to reactivate the server using the web browser.

After reactivation delete the following registry keys and reboot the server!

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM

  • Certificate
  • X509 Certificate
  • X509 Certificate ID
  • X509 Certificate2

These registry keys will rebuild with lower security after reboot (see also [14]).

And, surprise, after reboot Remote Desktop Mobile (Windows CE5, Windows Mobile 6.x and Windows Embedded Handheld 6.5.3) can connect!

  • Thanks for the reply but may i ask what if i want to connect to a server that is a Windows 2012 Server R2 but NOT a TS server? What are the configurations that should be done in such a case (where Licensing Server will not be present)? – archergr Dec 4 '14 at 14:45
  • Read down where it says "What MS says" near the bottom and try that. But I'm not following you...you have to have TS/RDS to legally use a WinMobile RF device to "rdp" into a server. The default RDP for 2 "administrative sessions" can't be used. – TheCleaner Dec 4 '14 at 14:57
  • Ok i got it now, my bad. I will setup an TS/RDS with a License Server and will try again following the instructions. Thanks for the info! – archergr Dec 5 '14 at 9:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.