4

We are using SCCM 2012 SP1 CU5 (5.0.7804.1600) and on many of our Windows 7 clients updates are not installing. When I run "Machine Policy Retrieval & Evaluation Cycle" the C:\Windows\CCM\Logs\WUAHandler.log runs as expected I believe - the last few entries are:

Search Criteria is (DeploymentAction=* AND Type='Software') OR (DeploymentAction=* AND Type='Driver')
Async searching of updates using WUAgent started.
Async searching completed.
Successfully completed scan.

Then I run the "Software Updates Scan Cycle" and the C:\Windows\WindowsUpdate.log file also completes successfully:

2014-12-04  09:24:41:086    1036    3458    Report  CWERReporter finishing event handling. (00000000)
2014-12-04  09:24:41:296    2888    309c    COMAPI  - Updates found = 444
2014-12-04  09:24:41:296 2888   309c    COMAPI  ---------
2014-12-04  09:24:41:296    2888    309c    COMAPI  -- END -- COMAPI: Search [ClientId = CcmExec]
2014-12-04  09:24:41:296    2888    309c    COMAPI  -------------
2014-12-04  09:24:46:039    1036    3458    Report  CWERReporter finishing event handling. (00000000)

When the "Software Updates Deployment Evaluation Cycle" is run there are errors in C:\Windows\CCM\Logs \UpdatesDeployment.log:

Detection job ({47813475-0491-46E5-8CD1-B84B806B9844}) started for assignment ({a3c79c96-1ed1-456d-98e7-7b8a2b381775})
Started evaluation for assignment ({a3c79c96-1ed1-456d-98e7-7b8a2b381775})
Evaluation initiated for (12) assignments.
Job error (0x87d00244) received for assignment ({a3c79c96-1ed1-456d-98e7-7b8a2b381775}) action
Updates will not be made available

These errors show for each job. Any idea how to resolve it? Thanks

1

Is the experience common across all clients, or only a selection of clients?

-If all clients, I would check the content status of your update packages

-If only some clients, I would look at your boundary group configuration.

I wasn't able to find much info on that particular error, as I'm sure you were not as well. CMTrace.exe (you should definitely be using this, look in C:\Program Files\Microsoft Configuration Manager\tools for the utility) has a Error Lookup under the Tools menu. It reports the vague error:

87d00244: The object or subsystem has not been initialized.


Here is a bit of reference I found (actually, a really good post). Based on the information presented in your log snippets, it would seem that your Windows Update Agent is healthy on the affected clients, and the issue stems from ConfigMgr.

However, the Job Error 87d00244 referencing an assignment makes me think either WUA isn't healthy or ready, or the update content isn't available on the target machine. Can you check ccmcache for relevant update packages?

Also, can you please confirm you are not using IP Subnet boundaries? If you have odd size subnets (odd being anything other than /24), it's entirely possible there's a config issue there.


Another update:

Is it possible the selection of computers affected does not have the July 2014 Update for Windows Update (windows update agent) installed? This was apparently an issue for SCCM update infrastructure. (KB varies depending on OS version, see link for more info)

A guide to creating a collection query turned up some interesting info. I have a great many clients lacking this update, and it appears it can affect the ability to install later updates in some cases.

  • It seems to be affecting about 25% of machines (something like 175 in total). The boundary is set right I believe. The other thing is that in the Monitoring >> System Status both "Site Status" and "Component Status" are full of green ticks. I use CMTrace all the time, but didn't know about the Error Lookup part so thanks for pointing that out. – Kieran Walsh Dec 12 '14 at 9:03
  • With that number of machines, it's likely you're spanning subnets. That's why I asked the boundary question. That error is pretty vague. Are all client PCs in the same physical location? Are all distribution points healthy? – blaughw Dec 12 '14 at 15:03
  • Good thinking, but after checking it out, the machines are randomly placed across the site. – Kieran Walsh Dec 18 '14 at 9:05
  • What is the update content? Could it be that the updates are not processing because they're detected as not applicable for a given system? I will be brushing up on this myself and hopefully I'll have some good steps to narrow this down. – blaughw Dec 18 '14 at 15:58
0
  • Open the SCCM Console, Assets and Compliance and Devices

  • Right-click the computer receiving the error and select Install Client

  • In the Installation Options for the Client Push, make sure to check the Uninstall existing Configuration Manager client before the client is installed checkbox

  • OP has provided log info from clients. You're instructing him to remediate by first reinstalling the SCCM client? – blaughw Dec 11 '14 at 18:56
  • 1
    Yup, based on the error code, which is also related to client reinstall/update issues. Just try it on one machine, I mean there is no downside to it. – Kru Dec 11 '14 at 19:05
  • Thanks for the response, I have completely removed ccm from a few machines and resinstalled - no luck I'm afraid. – Kieran Walsh Dec 12 '14 at 9:05
0

While not specifically related to seeing this error code while running a Software Update Deployment Evaluation Cycle, other users have reported success using CCMCLEAN from the SMS 2003 toolkit to completely remove the ConfigMgr client and then re-install the client to resolve the same error code during the initial client installation. Please note that this software is no longer supported, but perhaps worth a try on a single client just to see if it helps.

Link to SMS 2003 Tookit 2 containing CCMCLEAN: http://technet.microsoft.com/en-us/systemcenter//bb676787.aspx

Technet thread describing same error during client install: https://social.technet.microsoft.com/Forums/en-US/d3cb3b25-8195-47dd-8121-993681c21b5e/cm2012-client-install-fails-with-unable-to-compile-sql-ce-script-file?forum=configmanagerdeployment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.