3

Just updated the BIOS of two Supermicro 1022G-URFs to R3.5. They've both the mainboard H8DGU-F with two onboard Intel 82576 NICs.

One of the two Supermicros doesn't have any visible NICs at all after this BIOS update. They are not even listed in the BIOS under network booting devices. So what've I already tried:

  1. Booting from an Ubuntu live CD with lspci | grep -i ethernet without any result (while this works on the working one).
  2. Updated the BIOS again with exactly the same image.
  3. Updated the IPMI to latest version.
  4. Kept the server off for like 10 minutes without luck (it was still connected to the power because the server is remote) will try to cut the power completely tomorrow.
  5. Changed some BIOS options like:
    • SR-IOV Supported: Enabled
    • Load Onboard LAN 1 Option Rom: Disabled
    • Load Onboard LAN 2 Option Rom: Disabled
    • IOMMU: Enabled

Some suggestions would be highly appreciated to get the two lost NICs back in the game.

Other possible fixes which I've not tried yet:

  1. Call Supermicro support.
  2. Search for separated NIC firmware.
  3. Follow this blog: http://blog.vodkamelone.de/archives/146-Unbricking-an-Intel-Pro1000-e1000-network-interface.html.
  • I wonder if a separate firmware update could be required for the NIC? – DerfK Dec 5 '14 at 23:19
  • Great question but I don't think so because there's nothing listed like that on the related Supermicro main board page. – Bart van Kleef Dec 5 '14 at 23:41
  • 4
    I'd call Supermicro support and describe your situation. – ewwhite Dec 6 '14 at 0:24
  • 3
    Did you reset the BIOS? Settings between major versions can be incompatible sometimes so resetting everything to defaults can clear up some odd issues. – Brian Dec 6 '14 at 3:03
  • Great suggestion Brian, loaded the "Fail-Safe Defaults" and after that it works! How could I even forget that! Thanks a million! – Bart van Kleef Dec 6 '14 at 7:36
4

Final solution was resetting the BIOS settings to "Fail-Safe Defaults" as suggested by Brian.

| improve this answer | |
0

Have you loaded optimal default after BIOS update? I was told by a Supermicro Tech support that you must load Optimal default in BIOS after flashing BIOS. Apparently it is a part of required step.

| improve this answer | |
  • No I didn't as mentioned I only loaded "Fail-Safe Defaults". – Bart van Kleef Dec 16 '15 at 22:28
  • I tried loading the optimal default and it resolved my issue for me. – user327523 Dec 17 '15 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.