On my local network there are (among others) 5 machines (running Debian Jessie or Arch) wirelessly connected to a Netgear WNDR4000 router. Below is a graph of the ping times to the router from each of the machines, collected over a period of around half an hour.

Ping times


  • When things are going well, the ping times are all below 3ms (under 1ms for two of the machines, including the problem machine purple)

  • At irregular intervals (of the order of 100s), three of these machines (red, green, purple) suffer degradation of ping times, while the other two appear unaffected.

  • The degradation periods coincide for all 3 machines.

  • The degradation for purple is two orders of magnitude more severe than for green and red, with ping times typically reaching over 20000ms for purple and 200ms for red and green.

  • If purple is physically moved nearer the router, the degradation completely disappears for purple while continuing as before for both red and green.

  • Red is 3m away and in direct line of sight from the base station; purple's usual location is about 10m away without direct line of sight.

This makes network access on purple intolarably slow (when it is in its normal location).

Can you suggest how to go about diagnosing and fixing the problem?

  • 1
    What is the wifi utilization at the router when the latency is high?
    – Greg Askew
    Commented Dec 6, 2014 at 14:56
  • @jacg did you find the source of the issue?
    – chicks
    Commented Jul 13, 2016 at 18:14
  • 1
    @chicks Not beyond discovering that the problem goes away when I manually pick a less noisy channel, no. As everything worked, the motivation to investigate further wasn't that strong. I have relocated since then, so I can't really follow it up either. Sorry.
    – jacg
    Commented Jul 14, 2016 at 7:23

4 Answers 4


Clearly you have an interference problem. Interference can come from passive elements like aluminum wall studs or thick floors, but those are not likely to show the periodic pattern you see. So something electric or electronic is periodically emitting. Finding it may be expensive or tough, but you have a few options.

  1. Graph more. It would be nice to make sure that this isn't a bandwidth limitation of your own creation. Looking at the bandwidth consumed on your uplink and each of the clients might lead to a similar looking graph and the source of your problem.

  2. Upgrade firmware. Being on the latest firmware could get you past a bug in their code causing this. Plus it helps reduce the chances of your router being remotely compromised.

  3. Mitigate it. Get a wifi analyzer for your phone. Look at who is using what bands when purple is pokey particularly. You may find that switching from 7 to 1 or 14 takes care of your problem. The analyzer should show you how the channels spread out into each other, so if you are in a really busy area going for the in-betweens of 4 or 11 would let you reduce the congestion.

  4. Migrate. Can you move the WAP to a different location? Placing it in a place just a foot away can significantly effect propagation within a building.

  5. Ground it. Make sure all of your AV equipment (TV's, stereos, etc.) is properly grounded.

  6. Find it. You could use a spectrum analyzer and a directional antenna to find the emitter, but the spectrum analyzer is big bucks. If you know a ham (an amateur radio operator), they may have this gear laying around already; offer them food and don't be surprised if more than one shows up. The ham will also know the FCC regs inside and out which will be great if you actually find the source. Without bribing anyone you could try cutting things off and see if gets better, but it might not be your stuff causing the problem. When dealing with VCR's and TV's you may need to completely unplug them.

Good luck.

  • 2
    Yes, this is a busy area. Channel 1, 6 and 11 were packed. The router picked channel 1, so I manually set it to 3. This seems to have fixed the problem: the graph has now been essentially flat for over four hours. Thank you.
    – jacg
    Commented Dec 6, 2014 at 22:06
  • 2
    Really loved the HAM radio operator observations, BTW :-)
    – jacg
    Commented Dec 6, 2014 at 22:39
  • Thanks for the feedback. I'm really glad you found a solution so quickly. :)
    – chicks
    Commented Dec 7, 2014 at 7:09
  • The How-To-Geek has a nice article about the issue. howtogeek.com/197268/…
    – Tomalak
    Commented Jul 13, 2016 at 18:04

I had it with an idle Wi-Fi network (Windows 7, various TP-LINK USB adapters). The ping fluctuates, making any remote terminal work a nightmare.

Solved by putting a constant load on the Wi-Fi network (e.g. fetching a small file from the router's web server in a loop).


To me, the intermittent nature indicates a hardware problem. Wireless routers go bad often. I'd try a new router and see if that doesn't resolve it. Maybe you can replace under warranty with Netgear if it's not too old?

Or you could always run a bunch of cat-5 and mini switches everywhere, the wired part of the router is probably fine.

  • 1
    Going wired to avoid the wireless is a good plan where you can anyway.
    – chicks
    Commented Dec 6, 2014 at 16:56

Go to Control Panel > Network and Sharing Center > Change adapter Settings > Right Click "Local Area Connection" > Properties

Disable "Internet protocol Version 6 (TCP/IPv6)" Disable "Link-Layer Topology Discovery Mapper I/O Driver" Disable "Link-Layer Topology Discovery Responder"

I had Ping spikes from 30ms up to 3000ms, sometimes even "Ping request timed out" reply. After I've done this my ping returned to normal again.

  • 3
    Disabling IPv6 is not recommended by MS technet.microsoft.com/en-us/magazine/2009.07.cableguy.aspx and an MVP: blogs.msmvps.com/acefekay/2010/05/27/… [...] From Microsoft’s perspective, IPv6 is a mandatory part of the Windows [OS] and it is enabled [...] Windows was designed specifically with IPv6 present, Microsoft does not perform any testing to determine the effects of disabling IPv6.[...] Therefore, Microsoft recommends that you leave IPv6 enabled, even if you do not have an IPv6-enabled network, either native or tunneled.
    – John K. N.
    Commented Apr 6, 2016 at 12:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .