1

I’m trying to connect to my first VM that I've created on Azure.

enter image description here

These are the steps I went through:

enter image description here

When trying to connect I get this screen:

enter image description here

It correctly lists the remote computer address as mymachine1231.cloudapp.net but for some reason the gateway is pointing to a server that exists at a company for which I work. At the time of creating the machine, I was VPN'd into this company. But the machine that I created has nothing to do with this company. I'm not understanding where it got this gateway address from?

After pressing connect I get this message:

enter image description here

What's going on here? How do I specify what gateway to use, and what should it be?

2

You should not be using an RD Gateway at all to connect to an Azure virtual machine. I'm guessing you might have the RD Gateway configuration left over from something at your work, maybe?

If you go to the Advanced tab in your Remote Desktop Connection, then click the "Settings" button under "Connect from anywhere," set the radio button back to "Automatically detect RD Gateway server settings" or "Do not use an RD Gateway."

Secondly, you need to open the endpoint in the Azure portal that allows access on port 3389 to your virtual machine.

Then, you should be able to RDP from your desktop directly to mymachine123.cloudapp.net.

Tip: Make sure that your virtual machine is set to only accept connections from "more secure" clients. This enables Network Level Authentication, and TLS.

| improve this answer | |
  • thanks so much! what do i need to do for the client to be able to access the machine in a "more secure" way? – Alex Gordon Dec 7 '14 at 4:27
  • 1
    @Yuck, On your server, go to Control Panel, System, Remote Settings, Remote tab, and make sure the "Allow connections only from computers running... (recommended)" is checked. On your client you don't have to do anything. – Ryan Ries Dec 7 '14 at 4:31
1

I had this problem myself this week, mine was a legitimate error and it took me ages to fix it :( I wrote it up here; RDS Gateway Connection Error

Pete

| improve this answer | |
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Gerald Schneider Nov 29 '19 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.