2

I have a Windows Server 2012 R2 server with the Remote Desktop Services role and I'm working on getting printer redirection working.

My users are in remote locations from the server and I want their local printer(s) to be redirected to the RDS server, so they can print.

I've read that there is a feature called "Easy Print", so without installing any printer drivers on the server or making any other changes I tried to redirect an HP printer.

The image below shows the printer properties for the redirected printer an HP LaserJet P3015.

Printer Properties

What I don't understand is why the "Model" and consequently the printer driver being used is "MS Publisher Imagesetter".

When I run the following,

C:\Users\Administrator>powershell -command "get-printerdriver *|select name"

name
----
Microsoft XPS Document Writer v4
HP LaserJet P3011/P3015 PCL6 Class Driver
Remote Desktop Easy Print
MS Publisher Imagesetter
Microsoft enhanced Point and Print compatibility driver
Microsoft enhanced Point and Print compatibility driver

Is Easy Print working and if so why does it not say "Remote Desktop Easy Print" as the "model" and printer driver?

My users also have another type of printer at some sites "Brother DCP-7065DN Printer" and the same thing happens when it is redirected, e.g. "MS Publisher Imagesetter" is the printer driver.

Do I need to install both the HP P3015 and Brother DCP-7065DN printer drivers on the RDS server?

UPDATE

As @KatherineVillyard and @joeqwerty answered, Easy Print is only supported when the clients are Windows.

I'm using Mac and Ubuntu clients. I have configured the clients to redirect and use the printer driver that the client is using. This is resulting in Windows RDS server installing the same driver on initial connection which is fine.

However, the printer once redirected continues to use "MS Publisher Imagesetter" and not the correct driver that was auto-installed.

I wonder if the reason for this is that the driver that gets installed on RDS is x64 and the clients are using x86 drivers. It tried installing the HP driver x86 version, but Windows Server complains and says that x86 drivers cannot be installed.

Any suggestions?

UPDATE 2

I've determined the issue is caused by the RDP client (FreeRDP) I'm using for both Mac and Ubuntu. I've submitted an issue explaining my findings and a workaround here.

Btw Microsoft's Remote Desktop application from Mac App Store is broken in this regard as there is no way to specify a specific printer driver and it always sets the driver to "MS Publisher Imagesetter" regardless of what is installed on the server.

  • What operating system are the clients running? – joeqwerty Dec 10 '14 at 2:45
  • Mac and Ubuntu. I haven't made any changes on the RDS server at all in terms of printing. I just connected a client and redirected the client's HP LaserJet. The client has the HP LaserJet PCL driver installed btw. – hydrajump Dec 10 '14 at 2:46
  • 1
    Oh. Well that's probably the problem. Non-Windows clients probably aren't supported. I haven't ever had to look into that, but that's my guess. – joeqwerty Dec 10 '14 at 2:48
  • What @joeqwerty said, yeah. – Katherine Villyard Dec 10 '14 at 3:18
3

I'm pretty sure that the printer should look like this:

enter image description here

There's a group policy setting:

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Printer Redirection

Also, Easy Print requires:

  • Remote Desktop Connection (RDC) 6.1
  • At least Microsoft .NET Framework 3.0 Service Pack 1
  • Ah the Easy Print requirements must explain it then. So, I guess I have to install each driver on the server after all. – hydrajump Dec 10 '14 at 2:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.