1

I am a beginner at managing a web server. And I am trying to learn how to troubleshoot an issue in Windows Server 2008 R2 running IIS 7.5 with a .NET 4.0 MVC website.

A website I manage has been running perfectly on a GoDaddy shared hosting plan for months. The last code update to the website was about 6 weeks ago. Several days ago the website stopped working from one minute to the next. Literally, it was more like one second to the next. One of the website admin's loaded a page, clicked a link and the next page never loaded. It has been down ever since.

I spent approx. 5 hours on the phone with 4 different GoDaddy technicians. Each time they determined that it was something in the website programming. (There are 2 of us that have access to the FTP of the site. We were both on our way to work when it stopped working.)

To test it, I published the site to our in-house dev server and it worked. I then re-published to the GoDaddy shared hosting and it still did not work.

The primary issue is that the site loads and loads and never comes up.

I thought maybe I would try another host, so I have spun up a Windows VM server on Rackspace (Win 2K8 R2), installed IIS 7.5, and have a basic site up and going. If I load a basic index.html file into the folder, I can see the "Hello world" message both locally on the web server and publicly from my office.

However, as soon as I load the ASP.NET content into the folder, I get the continuous load issue again.

As I said before, on the in-house dev server (which is also Win 2K8 R2 w/ IIS 7.5) the website works fine. For the moment, I have redirected the primary domain to my office IP, created some firewall rules to forward the packets, and am successfully hosting the website from the dev server. But this is not a long term solution.

I have spent hours in the last few days looking for solutions online, and have tried a number of things. But I have not had to troubleshoot a web hosting issue like this where I do not get any obvious error messages. I am looking for ways to troubleshoot this issue in IIS, or find error messages or logs, or something that could point me to the issue. But my lack of knowledge in managing a web server is getting in the way.

Thank you!

  • did you work this out as we've had a very similar problem. We solved it by creating a new app pool and then assigning the site to it (we couldn't restart the app pool as it wouldn't restart). We don't know if this is a permanent or temporary fix though! – Bex Dec 17 '14 at 16:40
  • I just posted my answer. It was a permissions issue. For some reason GoDaddy wiped out our folder permissions, but since we had originally set them very early in the project, we had forgotten that it was a thing we needed to watch out for. – jwatts1980 Jan 30 '15 at 15:05
2

I finally solved this last week.

There is a configuration file that is apart of our web application that needs read/write permissions for IIS. On our shared hosting account at GoDaddy, the permissions had been removed for some unknown reason. And when we loaded the application onto the test server, I basically just forgot that we had to reset those permissions on the new server. On our in-house dev server, the permissions had been configured way back at the beginning of the project.

On the test server we spun up at Rackspace, I added "Full Control" for the "IIS_IUSRS" to the parent directory where the file resides. On the GoDaddy shared hosting account, I went into the File Manager and set the permissions to web read/write on the directory.

The coding issue was that since the file is being accessed by a library that is used by the web application, the error was not being properly handled. If too many errors happen in a row, IIS can enter that continuous load state under certain conditions.

I stripped the site down to bare-bones and started adding dependencies back one at a time. Then when the error occurred, it wasn't so deep in the system, so I started actually getting helpful event logs. It's like the problem was so deep that it created an entirely unstable application and even the errors weren't being properly reported.

  • Hi, I encounter the same problem. May I know the process stripped the site down? – want_to_be_calm May 22 at 9:04
  • @want_to_be_calm I backed up all site files offline, and deleted them from the webserver. Then started by adding a basic index.html just to see it load. Our site had a front-end, customer facing part, which was static content, and a database driven backend. So, I started with the static content as I added back the files and folders and tested along the way.... – jwatts1980 May 22 at 14:31
  • ...In our case, when I added back the login page I started seeing errors because it was the first place that the database was being hit. Our application had a static resource (not a web.config) file with specific settings, and that file was not accessible because of permissions on the directory it was in. – jwatts1980 May 22 at 14:31
0

I would go and try to make an export of the site from one web server to another, then check .net version, app pools (including framework). If that does not work get process hacker or another tool to get some insight into what might be taking so much resources-IE some methods might take millions of CPU cycles.If all that does not work have a look into professional IIS 7 optimisation or test if it's performance with IE Tester, JMeter and see what content is taking so much time then try to optimist it.

  • We spun a test server up at Rackspace and had a similar issue. There however, it would not continuously load. It would time out after 30 seconds or so with a can't load page message. The event logs were no help. Eventually, I stripped the site down to nothing and started adding dependencies back one at a time until it crashed. – jwatts1980 Jan 30 '15 at 15:09
  • See if you have any extra packages installed on one of the servers, export the IIS configuration then via IIS (to be sure that you have the same settings), see if all the requirements are met like SSL, Authentification provider ... – Alex H Jan 30 '15 at 15:15
  • @jwatts1980 how to stripped the site down? – want_to_be_calm May 22 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.