2

We have 2 Remote Desktop Servers (Terminal Servers) with Windows Server 2008 R2 (WS 2008 R2) and Windows Server 2012 R2 (WS 2012 R2). I'm using Remote Desktop Services Manager (RDSM) installed on WS 2008 R2 to control user's sessions.

I've configured permissions for WS 2008 R2 with tsadmin.msc and now can remote control, send message, logoff etc. users' sessions on this server. On WS 2012 R2 I can do the same except Remote Control. I'm getting an "Access Denied" error, but I have administrative rights.

I've configured Computer Configuration\Policies\Administrative Templates\Windows Components\ Remote Desktop Services\Remote Desktop Session Host\Connections\Set rules for remote control of Remote Desktop Session Host server user sessions policy and Control Panel - System - Advanced system settings - Remote tab - the same error.

How can I allow Remote Control users' sessions on WS 2012 R2 from RDSM?

  • 1
    I have seen this happen frequently because of two things: 1.) The user's session is locked. 2.) The user has dual monitors. Do either of these apply to your situation? – SamAndrew81 Jul 21 '17 at 15:28
2

This is caused by users running Remote Desktop in multi-monitor mode. If they log out, uncheck the checkbox on the Display tab which says "Use all my monitors for the remote session", as so..., and then log back in, then you will be able to Remote Control their session.

There is unfortunately no work around for this issue.

0

Please chek registry HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\TermService\ObjectName

"NT Authority\NetworkService" is the value for a working RDP stand alone (no licensing server)

"LocalSystem" is not correct.

http://blogs.technet.com/b/askperf/archive/2010/07/08/the-case-of-the-mysterious-access-denied-aka-more-on-service-hardening.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.