1

I am having a world of problems here and can't see what is going wrong!

The Plan:

Use the Draytek to connect to the internet and provide WLAN access. Single port to connect to the GS724T and tag VLANs. Configure ports to belong to a particular VLAN, devices on a VLAN can communicate with each other and the Draytek only. If device is connected to a port belonging to VLAN2 the router provides an IP from LAN2 Optional: Each SSID to be on a different subnet to isolate traffic.

The failed setup:

I have set up VLANs on the Draytek using the same IDs that I used on the Netgear. I think it is best if I post screenshots of the relevant sections so you can see what I have tried.

Screenshots: http://imgur.com/a/njzJN

On the Port PVID Configuration page I tried changing ports 2-6 so the configured PVID was set to 20 but this resulted in no network access as I had a 169.x.x.x IP. If I manaually set my IP it still had no network access. The same result is seen if I uncheck any port from the general VLAN (VID 1).

I don't mind all IPs on the same subnet as long as devices can't communicate with devices in another VLAN. I would like devices connecting to the router wirelessly to have access to wired devices which are part of the same VLAN i.e. printing from an iPad to a networked printer.

Help would be much appreciated, I am sure I am missing something simple!

Thanks

  • Reading this it appears I am setting it up correctly but oddly enough when I assign a port to a VLAN it is not automatically removed from the default VLAN1. When I manually unassign it from VID1 I cannot get an IP. kb.netgear.com/app/answers/detail/a_id/8898/~/… – AK47UK Dec 17 '14 at 13:51
0

Ok well after a lot of frustration I reset the Draytek to factory settings and configured the VLAN section again, this time I only used LAN1 for subnets. Everything worked perfectly... I will be adding subnets soon to test as remote dial-in users will have to be isolated too but happy I got it working. Not sure what caused the strange behavious as I then reconfigured the rest of the router the same as before and it continued to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.