0

After I updated my mailman installation the server is now refusing to send the messages... and I can not figure out why. (I receive the messages since my mail account is on the same server, but they are not sent to other members of the list.)

syslog shows the following errormessage

postfix/smtpd[2541]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 454 4.7.1 <email@gmx.de>: Relay access denied; from=<list-bounces@domain.de> to=<email@gmx.de> proto=ESMTP helo=<myserver.stratoserver.net>

Any ideas on how to fix the problem or what I should look into?

Here is the output from postconf -n

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases, hash:/var/spool/postfix/plesk/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
disable_vrfy_command = yes
inet_interfaces = all
inet_protocols = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mailman_destination_recipient_limit = 1
message_size_limit = 102400000
mydestination = localhost.stratoserver.net, localhost, localhost.localdomain
myhostname = mywebsite.de
mynetworks =
myorigin = /etc/mailname
plesk_virtual_destination_recipient_limit = 1
readme_directory = no
recipient_delimiter = +
relayhost =
sender_dependent_default_transport_maps = hash:/var/spool/postfix/plesk/sdd_transport_maps
smtp_send_xforward_command = yes
smtp_tls_security_level = may
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_use_tls = no
smtpd_authorized_xforward_hosts = 127.0.0.0/8 [::1]/128
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated
smtpd_milters = , inet:127.0.0.1:12768
smtpd_proxy_timeout = 3600s
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sender_restrictions = check_sender_access hash:/var/spool/postfix/plesk/blacklists, permit_sasl_authenticated
smtpd_timeout = 3600s
smtpd_tls_cert_file = /etc/postfix/postfix_default.pem
smtpd_tls_key_file = $smtpd_tls_cert_file
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = , hash:/var/spool/postfix/plesk/transport
virtual_alias_maps = $virtual_maps, hash:/var/spool/postfix/plesk/virtual
virtual_gid_maps = static:31
virtual_mailbox_base = /var/qmail/mailnames
virtual_mailbox_domains = $virtual_mailbox_maps, hash:/var/spool/postfix/plesk/virtual_domains
virtual_mailbox_limit = 0
virtual_mailbox_maps = , hash:/var/spool/postfix/plesk/vmailbox
virtual_transport = plesk_virtual
virtual_uid_maps = static:30

Since hosts might be involved here the content of my /etc/hosts

127.0.0.1       localhost
::1             localhost ip6-localhost ip6-loopback
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

I am also getting another message from postfix/master - I don't know if its related:

message repeated 4 times: [ warning: master_wakeup_timer_event service pickup(public/pickup): Connection refused]
warning: master_wakeup_timer_event service qmgr(public/qmgr): Connection refused]
warning: master_wakeup_timer_event service pickup(public/pickup): Connection refused]

output from postconf -M: (updated 19.12.)

smtp       inet  n       -       -       -       -       smtpd
cleanup    unix  n       -       -       -       0       cleanup
tlsmgr     unix  -       -       -       1000?   1       tlsmgr
rewrite    unix  -       -       -       -       -       trivial-rewrite
bounce     unix  -       -       -       -       0       bounce
defer      unix  -       -       -       -       0       bounce
trace      unix  -       -       -       -       0       bounce
verify     unix  -       -       -       -       1       verify
flush      unix  n       -       -       1000?   0       flush
proxymap   unix  -       -       n       -       -       proxymap
proxywrite unix  -       -       n       -       1       proxymap
smtp       unix  -       -       -       -       -       smtp
relay      unix  -       -       -       -       -       smtp
showq      unix  n       -       -       -       -       showq
error      unix  -       -       -       -       -       error
retry      unix  -       -       -       -       -       error
discard    unix  -       -       -       -       -       discard
local      unix  -       n       n       -       -       local
virtual    unix  -       n       n       -       -       virtual
lmtp       unix  -       -       -       -       -       lmtp
anvil      unix  -       -       -       -       1       anvil
scache     unix  -       -       -       -       1       scache
maildrop   unix  -       n       n       -       -       pipe flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
uucp       unix  -       n       n       -       -       pipe flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail     unix  -       n       n       -       -       pipe flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp      unix  -       n       n       -       -       pipe flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n       n       -       2       pipe flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman    unix  -       n       n       -       -       pipe flags=R user=list:list argv=/usr/lib/plesk-9.0/postfix-mailman ${nexthop} ${user} ${recipient}
plesk_virtual unix -     n       n       -       -       pipe flags=DORhu user=popuser:popuser argv=/usr/lib/plesk-9.0/postfix-local -f ${sender} -d ${recipient} -p /var/qmail/mailnames
pickup     fifo  n       -       -       60      1       pickup
plesk_saslauthd unix y   y       y       -       1       plesk_saslauthd status=5 listen=6 dbpath=/plesk/passwd.db
qmgr       fifo  n       -       n       300     1       qmgr
smtps      inet  n       -       -       -       -       smtpd -o smtpd_tls_wrappermode=yes
plesk-85.214.241.135- unix - n   n       -       -       smtp -o smtp_bind_address=85.214.241.135 -o smtp_bind_address6= -o smtp_address_preference=ipv4
plesk-85.214.91.206- unix - n    n       -       -       smtp -o smtp_bind_address=85.214.91.206 -o smtp_bind_address6= -o smtp_address_preference=ipv4

closed as off-topic by HopelessN00b Feb 24 '15 at 3:55

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please edit your question and add output of command postconf -n – masegaloeh Dec 17 '14 at 21:08
  • added the output from postconf and the content of /etc/hosts – j00ls Dec 17 '14 at 23:14
  • Administration panels are off topic. – HopelessN00b Feb 24 '15 at 3:55
1

I don't why you set parameter mynetworks is blank. So, please edit the value of parameter mynetworks so it become

mynetworks = 127.0.0.1

And your master.cf was messed up too, maybe it is bug in plesk itself...

Solution:

  • Comment out this line pickup unix n - - 60 1 pickup
  • Comment out this line qmgr unix n - n 300 1 qmgr
  • Modify this line

    qmgr       fifo  n       -       n       1       1       qmgr
    

    to

    qmgr       fifo  n       -       n       300       1       qmgr
    
  • I changed it, restarted postfix but it did not solve the problem :( Maybe setting the server itself as a relay host might help? – j00ls Dec 18 '14 at 10:09
  • Yes, nothing has changed :( I added another postfix error that might be related to the original question - since I cant format it properly in this comment – j00ls Dec 18 '14 at 12:04
  • Added the output from postconf -M to the original question. – j00ls Dec 18 '14 at 12:46
  • I am sad to say it didn't help :( getting the same errormessages. Is "service postfix restart" enough or do I have to restart other services as well? – j00ls Dec 19 '14 at 17:30
  • updated the output of postconf -M in the question – j00ls Dec 19 '14 at 17:45
0

So I finally found a solution - even though I can not explain exactly explain why it started in the first place. I changed the mynetworks setting as follows:

original: mynetworks = 127.0.0.1

working: mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 VPS_IP

Not the answer you're looking for? Browse other questions tagged or ask your own question.