3

Had a serious power surge combined with an outage.

When all came back online, I had several I.T. issues. The big one was our Exchange database dismounted. Using Exchange 2010 SP3, RU4.

I ran the eseutil /mh command and found it was a dirty shutdown. Then I ran eseutil /p to repair the database. Database repair completed successfully. I then ran a chkdisk /R on the server itself (but not within eseutil - should I?). Database still would not mount, so I moved all the logs to another folder. Then the database mounted.

Next, the Transport Service would not stay started. To fix this I renamed the SenderReputation folder, restarted the Transport Service, and it worked.

Now - many issues. In my e-mail I lost all my inbox items, another user is getting sending errors "Event ID 10030" MSExchangeIS Mailbox Store "mismatch was detected between a view of the folder and the actual contents." Still other users are having odd issues here and there.

My diagnosis is that my database shell is corrupt and I need to create a new one. What do you guys think?

If you think this is what I need to do, I'd appreciate any reliable links on how this is best done.

Thanks everyone!

  • 1
    My diagnosis is that my database shell is corrupt and I need to create a new one - I have no idea what that means. Where are your backups? – joeqwerty Dec 22 '14 at 13:44
  • What the heck is a "database shell"? To be honest, the correct answer at this point is 1) hope you have recent backups, 2) Call Microsoft PSS. – Rob Moir Dec 22 '14 at 14:02
3

Check if your .edb files are not locked by your local antivirus (btw that can also be the cause of the corruption)

I found also move the file to a different hardrive in case the corruption is hardware related.

You look here: http://forums.msexchange.org/m_1800600673/mpage_1/key_/tm.htm#1800600673

1

This is what worked for me when I had RAID issues that corrupted my Exchange database.

  1. Check your storage. (By "storage," I mean your hard drive or RAID array.) Correct any errors here.
  2. Run Eseutil /P.
  3. After Eseutil /P runs successfully, run Eseutil /D.
  4. After Eseutil /D runs successfully, run Isinteg -fix -test alltests.

However, Microsoft itself says that the above procedure is a "last resort" and can result in data loss. Also, be aware that the above procedure requires a lot of time and disk space (more than twice the size of the database). So, you know. If restoring from backup is an option, you probably want to go that route instead.

And if restoring from backup isn't an option? Honestly, I think it's time to pull out the credit card and call Microsoft.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.