0

I know this might come across as a low-quality question; but nothing has been changed other than BIND settings which were reverted back (mind you, before restarting nothing was broken. The box can also resolve domain names). I've attached what slapd outputs to stderr in a pastebin link.

This all came about after my co-worker restarted the system. He swears nothing was changed. I've looked over the logs, but maybe better trained eyes will catch something I didn't. Obviously the logs are pretty verbose. Just a quick skim would mean a lot, I'm really at a loss here.

When I run "slapd -u root -h "ldap://127.0.0.1:389/ -d 256" this is the output:

http://pastebin.com/tRir8WGP

When I run "slapd -d 1" this is the output:

http://pastebin.com/TkYTtE8H

There are no other services listening on port 389, so nothing is tying up the port it's supposed to listen on.

Again, thanks for any help.

  • From the first paste it looks like it starts OK. You then hit control-C so it shuts down: "346 ^Cdaemon: shutdown requested and initiated." – Mark Wagner Dec 22 '14 at 20:25
  • I see that. If I start slapd and enable debugging, it starts fine. If I do not pass it the "-d" argument, it will refuse to start at all and "error out". – theCowardlyFrench Dec 22 '14 at 21:05
  • So without the "-d" no logs are generated at all? If there are some can you post them? – Mark Wagner Dec 22 '14 at 21:25
  • No, unfortunately. I'll look into configuring slapd to generate logs, and post them when I have them. – theCowardlyFrench Dec 23 '14 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.