3

I have snmpd running on an Ubuntu Linux system with a simple /etc/snmp/snmpd.conf:

rocommunity public

snmpd is listening on localhost. From the same system, I am running:

snmpwalk -v 1 -c public localhost

and part of the output is:

iso.3.6.1.2.1.92.1.1.1.0 = Gauge32: 1000
iso.3.6.1.2.1.92.1.1.2.0 = Gauge32: 1440
iso.3.6.1.2.1.92.1.2.1.0 = Counter32: 0
iso.3.6.1.2.1.92.1.2.2.0 = Counter32: 0

As you can see, I am only getting numeric OIDs for all but the iso object. I have also tried snmpwalk with the -Of option and snmptranslate. Both produce the exact same OIDs as above: that is, only numeric for children of iso.

Also, there are no other root level objects besides iso. Is that normal?

Thanks

3

Sounds like you are missing the MIB files that do the translation. To install them run:

apt-get install snmp-mibs-downloader

For licensing reasons they arent included by default. Installing that package will go download the standard ones from the internet. For specific manufactuer's custom SNMP values you will need to find their .mib files from the manufactuer's website.

Oh and you need to tell snmp to actually use the mibs! Edit /etc/snmp/snmp.conf to read:

mibs +ALL

| improve this answer | |
  • Installed this package. Still the same. Do I need to do anything else? – wirate Dec 22 '14 at 22:41
  • 1
    Got it working. Had to comment the mibs: line in /etc/snmp/snmp.conf. Thanks – wirate Dec 22 '14 at 22:43
  • @wirate yes, i forgot a step. Added it to the amswer. – Grant Dec 22 '14 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.