1

I am facing one problem. NTP server not sync the time automatically. If I change the the time of system then NTP server not able to correct it. After reboot the service of NTP it sync the time otherwise not. Checked the log also but did not found any thing.

log has this kind of entry. 23 Dec 16:37:49 ntpd[5413]: ntpd exiting on signal 15

output of ntpq -p is as follow.

ntpq -p
remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*ns.creativecont 130.102.128.23   3 u    8   64    1  303.276    3.860  20.429
 cachens2.onqnet 6.169.99.206     4 u    5   64    1  317.901   19.407  31.257
 a.pool.ntp.uq.e 216.218.192.202  2 u    6   64    1  266.111   18.447  29.693
 hosting.wireles 203.35.83.242    2 u    3   64    1  311.291    6.405  22.445
 juniperberry.ca 193.79.237.14    2 u   12   64    1  185.838   -2.730   0.004
 255.255.0.0     .BCST.          16 u    -   64    0    0.000    0.000   0.004

Please let me know if any one have any solution.

1

That's by desigm (assuming you're changing the time by a significant amount). See the ntpd nan page ...

   -g      Normally, ntpd exits with a message to the system log if the  offset  exceeds  the  panic
           threshold, which is 1000 s by default. This option allows the time to be set to any value
           without restriction; however, this can happen only once. If  the  threshold  is  exceeded
           after that, ntpd will exit with a message to the system log. This option can be used with
           the -q and -x options. See the tinker command for other options.

If you change the time on the NTP client manually by a sufficient amount then the NTP daemon thnks something odd is going on and exits. Normally the system's clock would only drift by small amounts and ntpd would handle that OK.

If you're still having problems then try starting ntpd with the -D flag (to get debug information) - that should show you what is happening in more detail.

If the NTP client is a virtual machine then you often need to take special steps to avoid having two systems trying to control the time - depends on the platform you're using.

  • Sorry but did not get your answer. Where i am wrong. – user260278 Dec 23 '14 at 8:39
  • And I am facing same issue when other computer try to sync with my Master NTP server. If I change the time on any computer it did not auto sync with my Master NTP server, I have to restart NTP service on other computer and then it will get the correct time from Master NTP server. Any Idea why NTP server not sync the time automatically ? Why I have to restart the service of NTP server ? – user260278 Dec 23 '14 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.