I try to install a kvm img in my vps, but after i install it, it show

root@wz:~# virsh list
 Id    Name                           State
 12    guaji                          paused

and i run

root@wz:~# virsh resume guaji
error: Failed to resume domain guaji
error: internal error: unable to execute QEMU command 'cont': Resetting the Virtual Machine is required

i try to reproduce it in vagrant with same kernel(ubuntu 14.04 lts), but it work well

my question is: how to fix it?

update i try `tail -n 1000 /var/log/libvirt/qemu/guaji-clone.log' and get:

char device redirected to /dev/pts/1 (label charserial0)
KVM: entry failed, hardware error 0x0
EAX=00000000 EBX=00000000 ECX=00000000 EDX=00000663
ESI=00000000 EDI=00000000 EBP=00000000 ESP=00000000
EIP=0000e05b EFL=00000002 [-------] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0000 00000000 0000ffff 00009300
CS =f000 000f0000 0000ffff 00009b00
SS =0000 00000000 0000ffff 00009300
DS =0000 00000000 0000ffff 00009300
FS =0000 00000000 0000ffff 00009300
GS =0000 00000000 0000ffff 00009300
LDT=0000 00000000 0000ffff 00008200
TR =0000 00000000 0000ffff 00008b00
GDT=     00000000 0000ffff
IDT=     00000000 0000ffff
CR0=60000010 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
Code=85 00 87 00 89 00 8b 00 00 00 86 00 88 00 8a 00 8c 00 00 90 <2e> 66 83 3e a4 65 00 0f 85 53 f2 31 c0 8e d0 66 bc 00 70 00 00 66 ba 4f 3c 0f 00 e9 b1 f0
(reverse-i-search)`tl': tl /var/log/libvirt/qemu/guaji-clone.log
  • Please describe fully the host system which is having the problem. Hardware, Linux distribution version, kernel, and anything else that may be interesting or unusual about it. Dec 24 '14 at 21:39

virsh destroy guaji

virsh start guaji

This should get the VM up if there are no configuration or hardware problems

  • I doesn't work, i only reproduce this bug on digitalocean ubuntu14.04, i think it's there hardward problem
    – anyvoleki
    Dec 25 '14 at 3:39

In my Ubuntu 16.04 ppc64el system, disabling SMT has fixed it:

sudo ppc64_cpu --smt=off

I faced this same error once when I changed os->loader->type from pflash to from in order to enable snapshots. I did it within Virt-Manager XML viewer and I don't know why, but the value changed from /usr/share/OVMF/OVMF_CODE.fd to usr/share/OVMF/OVMF_CODE.ms.fd.

I just undid this change and my VM was booting again. So one should double-check XML definitions.


I migrate my app from digitalocean to linode, very thing work well, I think the reason is digitaloccean close "intel vt" in its server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.