1

I'm running Squid 3.3.8 on Ubuntu 14.04.1 as a regular proxy without any SSL intercept tricks. When I visit a HTTPS site on a client using the Internet Explorer, all CONNECT requests are logged just fine. When I visit the same sites using Chrome, Squid logs only a few requests of embedded resources on separate domains (such as fbstatic-a.akamaihd.net) immediately, but not the domain I entered in the address bar of the browser (in this case facebook.com). Edit: These are logged a few minutes later, I tried it with http://www.google.com, https://www.facebook.com and a few online banking sites.

Edit: What's the reason for this behavior? Is there any way to control it?

  • Most likely your chrome does not use your proxy – PF4Public Dec 27 '14 at 0:19
  • I'm pretty sure it's using it. First, the embedded resources are showing up in the log file, and second, port 443 is blocked in the firewall. When I run Chrome without proxy, it's not able to connect to the internet at all. – Malte Clasen Dec 27 '14 at 0:35
  • Show us your configs then. Squid, iptables, squid log excerpts, maybe tcpdump would be useful. – PF4Public Dec 27 '14 at 0:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.