2

I installed the latest fail2ban from centos/epel I have added the ssh enabled option in jail.local. I have tried with action and banaction = firewallcmd-ipset neither made any difference. iptables-multi was originally in the config and I changed that after i noticed it wasnt banning. I have tried listing iptables rules as well as firewall-cmd --list-all-zones and nothing is listed. also the ban log has a couple of already banned messages in it.
NOTICE [sshd] 61.174.51.204 already banned

0

If you check the action.d directory, you will find all firewalld-related actions forgot to put on reload command after adding the rule to DROP or REJECT the source IPs by fail2ban, reload is important due to it makes the rules to be accepted by FirewallD. I suggest you to modify the actions to fit what you need, however, IMHO, FirewallD acts like a manger to control iptables and it's more suitable for workstation than server environment. Thus, the most efficient way to solve your problem is,

systemctl stop firewalld

systemctl mask firewalld

and enable your iptables.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.