Coming back from a 4-day weekend, I noticed the A/C had been turned off for the duration of the long weekend and the heat was around 80-82 degrees. The HP ProLiant DL185G5 was running but the system fans were running at full RPMs but the system itself was not responding.

I switched the KVM to that particular server and the monitor could not detect video and keyboard was not coaxing a response. I plugged in a separate monitor/mouse to make sure it wasn't the KVM switch, still no luck. I tried holding down the power button however the server was not shutting down upon holding the button in for 5+ seconds so I cut the power to the power array it was running on and turned it back on.

When I switched it back on, the monitor displayed the ProLiant logo and began to boot\ without error.

Upon booting ESXi, the configuration loads up to approximately 97% and then I am met with this message:

"Relocating the modules and starting the kernel..."

The system hangs right here. I researched this problem and it seems to commonly happen with ESXi 5.5 installations on particular systems. Most fixes imply it is a video adapter problem and running in headless mode will work. I tried this but to no avail. I also read it was due to my KVM monitor not supporting 1024 x 768 (it does not), but booting without any monitor plugged into the machine doesn't seem to work either.

Before I start an ESXi reinstallation, I was wondering if any actual ESXi gurus can lend a hand to a Microsoft Hyper-V guy and suggest any possible troubleshooting steps to take prior to what I've done/intend to do.

Are there any troubleshooting steps I can take to get around where ESXi hangs at Relocating the modules and starting the kernel?

Any help would be great.

  • Rambling... What's your real question here? Are you wondering why the server won't boot?
    – ewwhite
    Dec 29 '14 at 14:56
  • @Brandon welcome to ServerFault, your first question is a good quality question, but remember to clearly specify what exactly your question is.
    – MDMoore313
    Dec 29 '14 at 15:00
  • @BigHomie Thank you. My question is whether or not there are any troubleshooting steps I can take to get around where ESXi hangs at "Relocating the modules and starting the kernel".
    – Brandon
    Dec 29 '14 at 15:03
  • Was just trying to provide all information I thought might be pertinent to the problem considering I'm not at all an advanced ESXi admin.
    – Brandon
    Dec 29 '14 at 15:09
  • How long does the server hang? How long have you let it sit at that spot? Can you provide the exact build number of the ESXi installation? (it should show up on the yellow and grey screen)
    – ewwhite
    Dec 29 '14 at 15:10

I finally pulled the server out of the enclosure and began testing the hardware. After pulling out all of the memory modules other than 2, the server booted into esxi as normal. After systematically adding memory modules to the server, booting, checking if bootup was successful, I narrowed the issue down to a bad memory module. Leaving that particular module out, the esxi server booted correctly/successfully.

  • I also faced the same with Dell (very old) Desktop PC running VMware Exsi 5.5. Removed all 3 RAM blocks and started adding 1 by 1 and found the malfunctioning RAM block. Thanks @Brandon. You are a great help even after 5 years. :) Feb 17 '19 at 10:52
  • I further tested and found that, 2 RAM are identical while other one is different. So I finally found that modules in the adjacent banks, for example 1,2 needs to be same. So I put the particular module to no 3 bank and everything is fine. Feb 17 '19 at 11:04

A lot of times it is a bug or incompatibility between VMWare and the hardware you are using but this doesn't mean it can't work.

What you do is hit "Shift + O" and add the following:


After you should login by SSH and make the change permanent (otherwise you will have to manually hit Shift + O and the above with each boot):

esxcfg-advcfg -k TRUE ignoreHeadless

Source: http://realtechtalk.com/Relocating_modules_and_starting_up_the_kernel_VMWare_ESXi_67_Error_and_Solution-2032-articles


Shift+O to modify the Boot instructions, then clear runweasel field and enter this value and push ENTER


In addition to John P Boyle/masegaloeh's answer about setting ignoreheadless, you can also disable headless under your ACPI settings in the BIOS. At least on Supermicro Servers this appears to help and you don't have to hack a boot argument for ESXi.

See additional information if curious here. https://communities.vmware.com/message/2169210


I had same problem on HP G8, nothing worked. I tried different esxi versions, removed memory modules, add boot parameter, remove disks. After 2 days of searching I had the idea to reset bios to default and wow! Before that the Unetbootin menu was loading in slow motion, now is normal. The server was refurbished and... yes I know, I should to this from beginning.


Believe it or not, HP DL380 G9 server, same problem, I was deliberatly choosing F9 boot option then selecting Usb flash drive and getting same error, I let it boot itself (probably UEFI) then boom! IT WORKS...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.